Closed Bug 1332961 Opened 7 years ago Closed 7 years ago

Layout is extremely slow on rustdoc source listings

Categories

(Core :: Layout, defect)

50 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1288938

People

(Reporter: nagisa, Unassigned)

Details

Attachments

(1 file)

Attached file The offending page
Originally reported in the Rust repository[1].

[1]:https://github.com/rust-lang/rust/issues/39240#issuecomment-274366421

The layout of source code listings generated by rustdoc (sample attached) is extremely slow on Firefox.

If the `font-family` rule on line 130 of rustdoc.css is removed, the page layouts quickly.

> code, pre {
>    font-family: "Source Code Pro", Menlo, Monaco, Consolas, "DejaVu Sans Mono", Inconsolata, monospace;
>    white-space: pre-wrap;
> }

Does not reproduce on a Webkit browser.
I cannot reproduce this on Firefox Developer Edition. I guess it is a dup of bug 1288938 (and thus would be fixed in the next release). Could you confirm that it doesn't appear on Beta or DevEdition?
Flags: needinfo?(simonas+bugzilla.mozilla.org)
I will try to re-reproduce this once the fix rides the trains to stable. Hoping needinfo reminder will fire in a timely manner :)
Flags: needinfo?(simonas+bugzilla.mozilla.org)
Flags: needinfo?(simonas+bugzilla.mozilla.org)
I raised the original issue on github - I've tried on firefox hg repo and I don't get the issue. Is it worth leaving this issue open until it lands in firefox stable, to avoid more duplicates?
No. In general, we close bugs when they get fixed in mozilla-central (that is, where the Nightly from). So let's mark it duplicate of bug 1288938.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
That fix landed in FF51, so it should be in Firefox Release by now. Please reopen the bug if it doesn't appear to be fixed.
Flags: needinfo?(simonas+bugzilla.mozilla.org)
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: