Closed Bug 1333002 Opened 3 years ago Closed 3 years ago

Fix a misleading indentation in PeerConnectionCtx.cpp

Categories

(Core :: WebRTC: Signaling, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla54
Tracking Status
firefox51 --- unaffected
firefox52 --- unaffected
firefox53 --- fixed
firefox54 --- fixed

People

(Reporter: Sylvestre, Assigned: Sylvestre)

References

(Blocks 1 open bug)

Details

(Keywords: coverity, Whiteboard: [CID 1398285])

Attachments

(1 file)

if observerService is NULL, we will crash
Comment on attachment 8829349 [details]
Bug 1333002 - Fix a misleading indentation in PeerConnectionCtx.cpp

https://reviewboard.mozilla.org/r/106470/#review107426
Attachment #8829349 - Flags: review+
Pushed by sledru@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/72fba5033e0c
Fix a misleading indentation in PeerConnectionCtx.cpp r=drno
Assignee: nobody → sledru
Comment on attachment 8829349 [details]
Bug 1333002 - Fix a misleading indentation in PeerConnectionCtx.cpp

https://reviewboard.mozilla.org/r/106470/#review107470

THough nils already r+'d... this is why we have the rule about bracing.
Attachment #8829349 - Flags: review?(rjesup) → review+
https://hg.mozilla.org/mozilla-central/rev/72fba5033e0c
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla54
Let's uplift this.
Flags: needinfo?(drno)
Comment on attachment 8829349 [details]
Bug 1333002 - Fix a misleading indentation in PeerConnectionCtx.cpp

Approval Request Comment
[Feature/Bug causing the regression]: bug 1318180
[User impact if declined]: if observerService is NULL, we will crash
[Is this code covered by automated tests?]: No clue
[Has the fix been verified in Nightly?]: Don't know how to reproduce as it is pure coding issue
[Needs manual test from QE? If yes, steps to reproduce]:  No
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: Less than keeping it in the code. This is an obvious programming mistake
[Why is the change risky/not risky?]: We will be in a better place with the patch because we are avoiding a call on a null object.
[String changes made/needed]: Non
Attachment #8829349 - Flags: approval-mozilla-beta?
Attachment #8829349 - Flags: approval-mozilla-aurora?
Comment on attachment 8829349 [details]
Bug 1333002 - Fix a misleading indentation in PeerConnectionCtx.cpp

crash fix, aurora53+, beta52+
Attachment #8829349 - Flags: approval-mozilla-beta?
Attachment #8829349 - Flags: approval-mozilla-beta+
Attachment #8829349 - Flags: approval-mozilla-aurora?
Attachment #8829349 - Flags: approval-mozilla-aurora+
Flags: needinfo?(drno)
AFAICT, Beta52 isn't affected?
Flags: needinfo?(sledru)
Ryan you are right. This only affects 53, because that is where I landed bug 1318180.
Attachment #8829349 - Flags: approval-mozilla-beta+
Flags: needinfo?(sledru)
You need to log in before you can comment on or make changes to this bug.