Vary header is incorrect for KumaScript response

RESOLVED FIXED

Status

Mozilla Developer Network
KumaScript
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: jwhitlock, Assigned: rjohnson)

Tracking

Details

(Whiteboard: [specification][type:bug])

(Reporter)

Description

a year ago
What did you do?
================
Request a rendered document from the KumaScript service, and look at the headers, such as in the development environment:

curl -I http://localhost:9080/docs/en-US/HTML

What happened?
==============
Response is:

HTTP/1.1 200 OK
0: V
1: a
2: r
3: y
X-Powered-By: Express
Vary: [object Object],X-FireLogger
X-Cache-Key: response-cache:6d9f35bfd1bec140b490cefe2dbe16402035622c
Age: 16
Date: Mon, 23 Jan 2017 17:28:40 GMT
Last-Modified: Mon, 23 Jan 2017 17:28:24 GMT
ETag: W/"2bd3-3989R20XFSaU3AOr++gMpw"
X-Cache: HIT
Content-Type: text/html; charset=utf-8
Content-Length: 11219
Connection: keep-alive


The Vary header appears to have a JS object instead of a string:

Vary: [object Object],X-FireLogger

The four "numeric" headers (0: V, 1: a) appear to be a related error.

What should have happened?
==========================
The Vary header should not include [object Object]. The numeric headers should be omitted.

Is there anything else we should know?
======================================
This may be related to the node v6 update, assigning to tracking bug for now.
(Reporter)

Updated

a year ago
Blocks: 1333116
(Assignee)

Updated

a year ago
Assignee: nobody → rjohnson
Status: NEW → ASSIGNED
(Assignee)

Comment 1

a year ago
This was due to the node v6 update. The node v6 update included an upgrade to version 4 of the express module, which the firelogger module (0.1.0) did not support.

See https://github.com/mozilla/kumascript/pull/106
(Reporter)

Comment 2

a year ago
After change, the headers look good:

HTTP/1.1 200 OK
X-Powered-By: Express
Vary: X-FireLogger
X-Cache-Key: response-cache:6d9f35bfd1bec140b490cefe2dbe16402035622c
Content-Type: text/html; charset=utf-8
Content-Length: 0
ETag: W/"0-1B2M2Y8AsgTpgAmY7PhCfg"
Last-Modified: Tue, 07 Feb 2017 14:17:24 GMT
Date: Tue, 07 Feb 2017 14:17:24 GMT
Connection: keep-alive
(Reporter)

Updated

a year ago
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
(Reporter)

Comment 3

a year ago
Merged, deployed, and confirmed on production web server.
You need to log in before you can comment on or make changes to this bug.