Closed Bug 1333371 Opened 3 years ago Closed 3 years ago

Crash in nsPIDOMWindow<T>::GetDocGroup

Categories

(Core Graveyard :: DOM: Flyweb, defect, critical)

52 Branch
x86
Linux
defect
Not set
critical

Tracking

(firefox52 unaffected, firefox53 fixed, firefox54 fixed)

RESOLVED FIXED
mozilla54
Tracking Status
firefox52 --- unaffected
firefox53 --- fixed
firefox54 --- fixed

People

(Reporter: calixte, Assigned: bevis)

References

(Blocks 1 open bug)

Details

(Keywords: crash, Whiteboard: [clouseau])

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-a1b34bc7-505c-4dfc-8d3f-d41b72170123.
=============================================================

There is one crash on nightly with build-id 20170123163559 and in analyzing the backtrace it could be a regression introduced by patch [1] to fix bug 1314833.

[1] https://hg.mozilla.org/mozilla-central/rev?node=d3cfaafedb4339897fcede34a67125a4d16a7b98
Flags: needinfo?(btseng)
Blocks: 1314833
Flags: needinfo?(btseng)
The aOwner could be null from the caller at:
http://searchfox.org/mozilla-central/source/dom/flyweb/FlyWebPublishedServer.cpp#482
I'll provide a patch to fix this asap.
Assignee: nobody → btseng
Component: Audio/Video: Playback → DOM: Flyweb
Hi Bill,

Sorry for not capturing this problem in bug 1314833.
May I have your review for this quick fix?

Thanks!
Attachment #8830169 - Flags: review?(wmccloskey)
Attachment #8830169 - Flags: review?(wmccloskey) → review+
Pushed by btseng@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/4477cdb38b11
Fallback to AbstractThread::MainThread() if the inner window is not provided. r=billm
https://hg.mozilla.org/mozilla-central/rev/4477cdb38b11
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla54
btseng: We're still crashing with this patch. We were not crashing until Bug 1314833 landed. See the new log of the crash here:

https://bugzilla.mozilla.org/show_bug.cgi?id=1333909#c7
Flags: needinfo?(btseng)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: mozilla54 → ---
Removing ni? flag since this issue is now resolved.
Flags: needinfo?(btseng)
change status to resolved according to comment 7.
Status: REOPENED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → FIXED
Comments 6 & 7 paint a rather muddy picture of things, but OK. Please request Aurora approval on this patch when you get a chance.
Flags: needinfo?(btseng)
Target Milestone: --- → mozilla54
Comment on attachment 8830169 [details] [diff] [review]
Patch: Fallback to AbstractThread::MainThread() if the inner window is not provided.

Approval Request Comment
[Feature/Bug causing the regression]:Bug 1314833.
[User impact if declined]:Crash when accessing FlyWeb API.
[Is this code covered by automated tests?]:There is no test case in dom/flyweb but was manually tested accorrding to https://bugzilla.mozilla.org/show_bug.cgi?id=1333909#c8
[Has the fix been verified in Nightly?]:Yes, it was manually tested in https://bugzilla.mozilla.org/show_bug.cgi?id=1333909#c8
[Needs manual test from QE? If yes, steps to reproduce]: No. It's been tested according to https://bugzilla.mozilla.org/show_bug.cgi?id=1333909#c8
[List of other uplifts needed for the feature/fix]:No.
[Is the change risky?]:No.
[Why is the change risky/not risky?]:It's not risky because we have add a nullptr check to prevent the same crash happens again.
[String changes made/needed]:No.
Flags: needinfo?(btseng)
Attachment #8830169 - Flags: approval-mozilla-aurora?
Comment on attachment 8830169 [details] [diff] [review]
Patch: Fallback to AbstractThread::MainThread() if the inner window is not provided.

Fix a crash and was verified in nightly. Aurora53+.
Attachment #8830169 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Whiteboard: [clouseau]
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.