Closed Bug 1333428 Opened 3 years ago Closed 3 years ago

Intermittent browser/base/content/test/general/browser_trackingUI_telemetry.js | Total page loads - Got 2, expected 1

Categories

(Firefox :: Protections UI, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 55
Tracking Status
firefox-esr52 --- unaffected
firefox53 --- unaffected
firefox54 --- fixed
firefox55 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: mrbkap)

References

Details

(Keywords: intermittent-failure, Whiteboard: [stockwell fixed])

Attachments

(1 file)

Component: Telemetry → Tracking Protection
Product: Toolkit → Firefox
I did many retriggers:
https://treeherder.mozilla.org/#/jobs?repo=autoland&filter-searchStr=osx%20bc6%20opt%20e10s&tochange=916023361969b0d86de926f3d5c00dc6d9f62934&fromchange=bb5c698bff0a4d73ee015230818faacc587b07d5&selectedJob=86005678

and the root cause here is e10s multi from bug 1336398.


this spiked up with 32 failures in the last 6 days:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1333428&startday=2017-03-06&endday=2017-03-23&tree=all


:mrbkap, as you are the patch author of the patch which has triggered this, can you take a stab at the root cause?  I have included :bgrins and :mattn on the cc list as they authored/reviewed the test case originally.
Blocks: 1336398
Flags: needinfo?(mrbkap)
Whiteboard: [stockwell needswork]
I'm looking into this. I have a theory that I'm testing now.
Flags: needinfo?(mrbkap)
Attachment #8851831 - Flags: review?(felipc)
I might be jumping the gun, but this appears to be the third or fourth intermittent that's caused by the about:blank load triggering something too early. :-/
Comment on attachment 8851831 [details]
Bug 1333428 - Wait for loads on new tabs to avoid double-counting.

https://reviewboard.mozilla.org/r/124032/#review126818
Attachment #8851831 - Flags: review?(felipc) → review+
Pushed by mrbkap@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f25c04e26f61
Wait for loads on new tabs to avoid double-counting. r=Felipe
Assignee: nobody → mrbkap
Whiteboard: [stockwell needswork] → [stockwell fixed]
https://hg.mozilla.org/mozilla-central/rev/f25c04e26f61
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
You need to log in before you can comment on or make changes to this bug.