Closed Bug 1333557 Opened 4 years ago Closed 4 years ago

Fix packaging failure when purple is not enabled

Categories

(Instantbird :: Other, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Instantbird 54

People

(Reporter: aleth, Assigned: aleth)

Details

Attachments

(1 file)

This would break current nightlies if they weren't broken anyway. 

The cause is that the code that sets MOZ_PURPLE checks for the existence of the purple directory instead of for the mozconfig flag.
Attachment #8830021 - Flags: review?(clokep)
Assignee: nobody → aleth
Status: NEW → ASSIGNED
This works as --enable-extensions=purple adds 'purple' to MOZ_EXTENSIONS, which we check for here. The code that handles --enable-extensions already checks for the existence of a purple dir, so we don't need to repeat that in the im configure.
Attachment #8830021 - Flags: review?(clokep) → review+
And it fixes packaging because that already checks for MOZ_PURPLE.
https://hg.mozilla.org/comm-central/rev/ebbcdc168ef5de1b525b924815057e3207bc552e
Bug 1333557 - Use the extensions mechanism to set MOZ_PURPLE. r=clokep
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Instantbird 54
You need to log in before you can comment on or make changes to this bug.