-compose needs to accept mailto: (treat all "hanging" command parameter as URLs?)

RESOLVED DUPLICATE of bug 209403

Status

--
enhancement
RESOLVED DUPLICATE of bug 209403
17 years ago
10 years ago

People

(Reporter: smeredith, Assigned: law)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
If the -compose command line argument were changed to allow a complete mailto:
URL, a user could configure IE to use Mozilla Mail as the app to use when a
mailto: URL is clicked on. You can pass a URL to -compose, but mail interprets
it as a page to attach.

When you click on a mailto: URL in IE, IE looks in the registry for the default
mail application to use, and passes the entire mailto: URL to that app. You can
almost set it up correctly now using "mozilla.exe -compose to=%1", but that puts
the entire mailto: URL in the To field, not just the address as Mozilla expects.

For details on setting up IE to use a different mail app, see
http://msdn.microsoft.com/library/default.asp?url=/workshop/browser/configuration/clientreg/clientregistrylayout.asp
-->varada
Assignee: ducarroz → varada
taking all of varada's bugs.
Assignee: varada → sspitzer

Comment 3

16 years ago
Note that the desired action is possible using -mail rather than -compose:
   mozilla -mail mailto:no@spam.com
in Windows, configure for
   "<path>\mozilla.exe" -mail "%1"

Given that -compose with no args starts an empty composition window,
it makes a lot of sense to make this change.

Comment 4

16 years ago
see http://www.mozilla.org/docs/command-line-args.html for -compose syntax.
Since mozilla mailto:blah@blah.com and mozilla -mail mailto:blah@blah.com work
(except annoyance bug 204752) -> wfm
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Summary: [RFE] -compose needs to accept a complete mailto: URL → -compose needs to accept a complete mailto: URL

Comment 5

16 years ago
I think that's a short-sighted resolution, and I am boggled that an ENHANCMENT 
can be marked WorksForMe.  The program may work well enough for you, Daniel, but 
it is inconsistent in its design.  The   -mail   switch is designed to bring up 
the mail window, and the   -compose    switch is designed to bring up a compose 
window.  It is a fluke that    -mail <URL>    brings up the compose window (and 
only the compose window, not the mail window).

Comment 6

16 years ago
Reopen bug for consideration by module owner.

But consider the following:
1. -compose follows special syntax different from mailto:, and that
  could lead to problems
2. current -compose syntax is the same as Netscape 4.x's
3. you can't do attachment and possibly more from mailto:, so we
  shouldn't change the syntax

Maybe we should handle all "hanging" parameter as URL, e.g. if
a parameter is ill-formed, the command handler just spit it out
to the URL command handler.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 7

16 years ago
-> xp app:cmd-line features
Assignee: sspitzer → law
Status: REOPENED → NEW
Component: Composition → XP Apps: Cmd-line Features
Product: MailNews → Browser
QA Contact: esther → sairuh
Summary: -compose needs to accept a complete mailto: URL → -compose needs to accept mailto: (treat all "hanging" command parameter as URLs?)

Comment 8

16 years ago
this sounds like a dup of a bug I did for mozilla thunderbird to add mailto
support as a window argument to the compose window:

http://bugzilla.mozilla.org/show_bug.cgi?id=209403

I believe this is a dup of that. This allows thunderbird to receive mailto url
clicks from browsers like firebird and IE. I suspect it addresses this issue to.

Marking as a dup. 


*** This bug has been marked as a duplicate of 209403 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE

Updated

10 years ago
Component: Cmd-line Features → Cmd-line Features
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.