Status

Calendar
Sunbird Only
RESOLVED FIXED
16 years ago
12 years ago

People

(Reporter: xyzzy, Assigned: Mike Potter)

Tracking

Details

(Reporter)

Description

16 years ago
This one is a two-for-one because we didn't quite kill bug 129861 (oops!):

1) Fix selection on event creation in week and day views, not just in month view.
2) In the event list, up and down arrows move the selection, but don't move the
corresponding selection in the view.  We should make sure that these say in sync
in all views.  ;)
(Assignee)

Comment 1

16 years ago
I'm going to redo the way that the selected event is watched.
This bug will be used to track it.
Blocks: 133324
Summary: More event selection issues → Redo Event Selection
(Assignee)

Comment 2

16 years ago
This is done in CVS. I'll make a new XPI for you to test out soon enough.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Reporter)

Comment 3

16 years ago
Tried this with 2002040203 build and April 2 XPI, and this seems to have gotten
worse: doesn't work in any view (regressed 129861) and arrow selections not
working  either.  Reopening.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 4

16 years ago
Mike:
  You're on windows right?  (I just want to make sure).
  I've got a build from the same day (2002040211) and it works for me in Linux.
  Are there any JS errors in the console?
(Reporter)

Comment 5

16 years ago
Yep, Windows 98.

Ok, I see what the problem is.  This seems to be working when the event is
inserted into a visible position in the Events tab, but not if it is scrolled
out of sight.  Watched the JS console while it did this, and no errors or warnings.
(Assignee)

Comment 6

16 years ago
Mike:
  Can you give me a reproduceable test case, and include the scrolling
information in it (ie. where were the events, on screen or off, when you did
things?)
Thanks. I'll test it here later this afternoon.
(Assignee)

Comment 7

16 years ago
I see problems with a lot of events.
Status: REOPENED → ASSIGNED

Comment 8

16 years ago
*** Bug 137369 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 9

16 years ago
To reproduce:
 Add about 17 events. Notice that when you click on event number 17 or so, that
the event does not get selected on the right hand side.
(Assignee)

Comment 10

16 years ago
This is fixed with the new design of events in a tree, below the month view.
Check it out in the new XPIs available now.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → FIXED
The bugspam monkeys have been set free and are feeding on Calendar :: Sunbird Only. Be afraid for your sanity!
QA Contact: colint → sunbird
You need to log in before you can comment on or make changes to this bug.