Refresh Firefox stalls

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: rockin.horea, Unassigned)

Tracking

51 Branch
x86_64
Windows 10
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20170118123726

Steps to reproduce:

I went to about:config and clicked on Refresh Firefox...


Actual results:

After completing all steps and displaying a "Almost done" window, the refresh action stalls. It shows a continuously moving process bar but doesn't progress from that no matter how much I wait. In the task manager, I can see the process uses 0.7% CPU and allocates and deallocates some bytes, but I eventually have to kill it in order to start FF again. Firefox feels refreshed though, all settings back to defaults and all addons gone.


Expected results:

The Refresh Firefox action should have completed successfully.
(Reporter)

Updated

2 years ago
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64
(Reporter)

Comment 1

2 years ago
It happened two times consecutively. The third time, it completed successfully, but I was required to select one of three user profiles with cryptic names (numbers). I chose the first profile, which it seems didn't store one new password, but otherwise feels OK.
User Agent 	Mozilla/5.0 (Windows NT 10.0; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID 	20170125094131

Hi Horea,

I haven't managed to reproduce your issue on the latest Firefox release or on the latest Nightly (54.0a1). In my case the Refresh is successful no matter how many times I do it.

Also in Steps to Reproduce I think you meant to write about:support, because the refresh button is there and not in about:config :)

Is the issue reproducible to you every time you try to refresh Firefox? If so, could you please check the latest Nightly (https://nightly.mozilla.org) and see if you can reproduce it there too?
Flags: needinfo?(rockin.horea)
(Reporter)

Comment 3

2 years ago
Hi Ciprian,

I haven't managed to reproduce it either now, possibly because one of two reasons I can think of:
- I'm running 52b1 now, but I don't think it's the main reason because:
- It could have been some kind of profile related problem and after several retries it just fixed itself automagically. I seem to remember having encountered something similar before, but I was too busy to log it.

I realize it's hard to hunt this down if I can't reproduce it anymore, so I won't mind if you close this as can't repro. I will let you know if it happens again.

P.S. Yes, should have been about:support. And I also didn't expect to get support from someone so close nearby, here in Cluj. Keep up the good work :)
Flags: needinfo?(rockin.horea)
Well then, I'll mark this as Resolved-Worksforme for the time being and if in the future you manage to run into this issue, feel free to reopen and needinfo me. 

P.S. To be honest I didn't expect to have a reporter that's so close by :D, I'm in Baia Mare.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.