Closed Bug 1333746 Opened 3 years ago Closed 3 years ago

Tooltip background color is dark, making text unreadable

Categories

(Core :: Widget: Gtk, defect)

51 Branch
Unspecified
Linux
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1319353
Tracking Status
firefox51 --- wontfix
firefox52 + fixed
firefox53 --- fixed
firefox54 --- fixed

People

(Reporter: LpSolit, Unassigned)

References

Details

(Keywords: regression)

Attachments

(1 file)

Attached image screenshot.png
I updated Firefox on Linux from 50.1.0 to 51.0 last night, and now all tootips use a dark background color, making the text in the tooltips unreadable, see the screenshot.
What GTK theme is this? Any chance you can find when exactly this broke? I suspect this is a GTK widget bug...
"gsettings get org.gnome.desktop.interface gtk-theme" returns 'Adwaita'.

No idea when it broke exactly. I updated from 50.1.0 to 51.0 directly. I didn't install any beta.
(In reply to Frédéric Buclin from comment #2)
> "gsettings get org.gnome.desktop.interface gtk-theme" returns 'Adwaita'.
> 
> No idea when it broke exactly. I updated from 50.1.0 to 51.0 directly. I
> didn't install any beta.

OK, would you be able to run mozregression to figure it out? ( http://mozilla.github.io/mozregression/ )
From the commandline something like:

mozregression --good 50 --bad 51

should get you a pushlog on mozilla-central fairly quickly.
beta3 (20161124073320) is fine, beta4 (20161128075558) is not.
OS: Unspecified → Linux
Thanks Alice. Looks like Karl is out. Martin, can you take a look as you reviewed the patch?
Component: Theme → Widget: Gtk
Flags: needinfo?(stransky)
Product: Firefox → Core
(In reply to :Gijs from comment #6)
> Thanks Alice. Looks like Karl is out. Martin, can you take a look as you
> reviewed the patch?

Sure. Which system/theme is that? Any Ubuntu or so? Thanks.
Flags: needinfo?(stransky) → needinfo?(alice0775)
[Tracking Requested - why for this release]: These fixes were uplifted and so they affect 51 and 52. We should ideally fix for 52.

(In reply to Martin Stránský from comment #7)
> (In reply to :Gijs from comment #6)
> > Thanks Alice. Looks like Karl is out. Martin, can you take a look as you
> > reviewed the patch?
> 
> Sure. Which system/theme is that? Any Ubuntu or so? Thanks.

Alice couldn't reproduce on Ubuntu (comment #5). Hopefully Frédéric can provide more specific info here (but it seems we can't needinfo them).
I'm using Mageia 5, KDE, theme Adwaita + Firefox 51.0.1 64-bit.
(In reply to Frédéric Buclin from comment #9)
> I'm using Mageia 5, KDE, theme Adwaita + Firefox 51.0.1 64-bit.

Thanks. Which gtk3 version there?
(In reply to Martin Stránský from comment #10)
> Thanks. Which gtk3 version there?

3.14.8
Tracking for 52, might be nice to have this fixed for ESR.
Yes, I can reproduce that on KDE + Gtk 3.14.15 (Fedora 21). Seems to be KDE only.
The bug is already fixed in trunk (54/53). I'll use mozregression to find exact commit which fixes that.
This is a dupe of Bug 1319353 which fixes that.
Status: NEW → RESOLVED
Closed: 3 years ago
Depends on: 1319353
Resolution: --- → DUPLICATE
Duplicate of bug: 1319353
Duplicate of this bug: 1336748
You need to log in before you can comment on or make changes to this bug.