Dragging a tab from one window to another crashes the browser

RESOLVED DUPLICATE of bug 1335335

Status

()

defect
P3
normal
RESOLVED DUPLICATE of bug 1335335
2 years ago
2 years ago

People

(Reporter: kats, Unassigned)

Tracking

(Blocks 1 bug)

53 Branch
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [gfx-noted])

If you drag a tab from one webrender-enabled window to another webrender-enabled window, it seems to (sometimes?) crash the browser. I caught it in a debugger and it looks like WebRenderBridgeParent::RecvClearCachedResources is getting called with mCompositorBridge null. Adding a null guard fixes the crash but I'm not sure if that's the right fix.
See Also: → 1335335
Forward duping because Sotaro had a WIP patch.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1335335
See Also: 1335335
You need to log in before you can comment on or make changes to this bug.