Stop building/remove the Mozilla SDK support

RESOLVED FIXED in Firefox 53

Status

defect
RESOLVED FIXED
2 years ago
Last year

People

(Reporter: benjamin, Assigned: benjamin)

Tracking

unspecified
mozilla54
Dependency tree / graph

Firefox Tracking Flags

(firefox53 fixed, firefox54 fixed)

Details

Attachments

(7 attachments)

Assignee

Description

2 years ago
There is no point in building or shipping the Mozilla SDK any more, since it's point was to enable binary component compilation and that is no longer supported. This bug tracks the various bits of turning off building the SDK (and automation which ships it) as well as removing various bits of code that support it.
Assignee

Updated

2 years ago
Assignee: nobody → benjamin
Status: NEW → ASSIGNED
Assignee

Comment 1

2 years ago
Posted file beetmoverscript PR
Attachment #8830451 - Flags: review?(jlund)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment on attachment 8830451 [details] [review]
beetmoverscript PR

with caveat inside the PR
Attachment #8830451 - Flags: review?(jlund) → review+

Comment 9

2 years ago
mozreview-review
Comment on attachment 8830457 [details]
Bug 1333826 - Remove the make-sdk build target, the INSTALL_SDK variable, and all the supporting packager/upload machinery,

https://reviewboard.mozilla.org/r/107204/#review108670

toolkit/mozapps/installer/package-name.mk still has a SDK_PATH definition - that could go away in this patch too.
Attachment #8830457 - Flags: review?(mshal) → review+

Comment 10

2 years ago
mozreview-review
Comment on attachment 8830459 [details]
Bug 1333826 - Remove SDK_FILES, SDK_LIBRARY, and related is_sdk support in the build goop,

https://reviewboard.mozilla.org/r/107208/#review108672

::: python/mozbuild/mozbuild/test/frontend/test_emitter.py
(Diff revision 1)
>          icons = files._children['icons']
>  
>          self.assertEqual(icons._strings, ['quux.icns'])
>  
> -    def test_sdk_files(self):
> -        reader = self.reader('sdk-files')

It looks like the python/mozbuild/mozbuild/test/frontend/data/sdk-files directory still exists - that should go away as well. (This patch removed test/backend/data/sdk-files, but not test/frontend/data/sdk-files)
Attachment #8830459 - Flags: review?(mshal) → review+

Comment 11

2 years ago
mozreview-review
Comment on attachment 8830456 [details]
Bug 1333826 - Remove all references to MOZ_AUTOMATION_SDK,

https://reviewboard.mozilla.org/r/107202/#review108674
Attachment #8830456 - Flags: review?(mshal) → review+

Comment 12

2 years ago
mozreview-review
Comment on attachment 8830458 [details]
Bug 1333826 - Remove SDK references from moz-automation.mk,

https://reviewboard.mozilla.org/r/107206/#review108676
Attachment #8830458 - Flags: review?(mshal) → review+

Comment 13

2 years ago
mozreview-review
Comment on attachment 8830461 [details]
Bug 1333826 - Remove a few references from .mk files,

https://reviewboard.mozilla.org/r/107212/#review108678
Attachment #8830461 - Flags: review?(mshal) → review+
Comment on attachment 8830460 [details]
Bug 1333826 - Remove SDK references from taskcluster beetmover,

LGTM, but redirecting to :jlund since I'm not familiar with beetmover.
Attachment #8830460 - Flags: review?(mshal) → review?(jlund)

Comment 15

2 years ago
mozreview-review
Comment on attachment 8830460 [details]
Bug 1333826 - Remove SDK references from taskcluster beetmover,

https://reviewboard.mozilla.org/r/107210/#review108866

::: taskcluster/taskgraph/transforms/beetmover.py
(Diff revision 1)
>      "target.apk",
>  ]
>  
>  
>  UPSTREAM_ARTIFACT_UNSIGNED_PATHS = {
> -    'linux64-nightly': _DESKTOP_UPSTREAM_ARTIFACTS_UNSIGNED_EN_US + [

we still need the 'linux64-nightly' and 'linux-nightly' keys and the _DESKTOP_UPSTREAM_ARTIFACTS_UNSIGNED_EN_US list of items as their value here.
Attachment #8830460 - Flags: review?(jlund) → review+

Comment 16

2 years ago
mozreview-review
Comment on attachment 8830460 [details]
Bug 1333826 - Remove SDK references from taskcluster beetmover,

https://reviewboard.mozilla.org/r/107210/#review108868

ugh, that was supposed to be a r- because the open issue is a blocker to landing :)
Attachment #8830460 - Flags: review+ → review-
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)

Comment 19

2 years ago
mozreview-review
Comment on attachment 8830460 [details]
Bug 1333826 - Remove SDK references from taskcluster beetmover,

https://reviewboard.mozilla.org/r/107210/#review108892

lgtm
Attachment #8830460 - Flags: review?(jlund) → review+
sorry I swore I already r+ the newest diff

Comment 21

2 years ago
Pushed by bsmedberg@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/075a7c952767
Remove SDK references from taskcluster beetmover, r=jlund
https://hg.mozilla.org/integration/mozilla-inbound/rev/3982ab8c8079
Remove all references to MOZ_AUTOMATION_SDK, r=mshal
https://hg.mozilla.org/integration/mozilla-inbound/rev/d08ce886e29c
Remove the make-sdk build target, the INSTALL_SDK variable, and all the supporting packager/upload machinery, r=mshal
https://hg.mozilla.org/integration/mozilla-inbound/rev/daa8b0da1484
Remove SDK references from moz-automation.mk, r=mshal
https://hg.mozilla.org/integration/mozilla-inbound/rev/6002440818d9
Remove SDK_FILES, SDK_LIBRARY, and related is_sdk support in the build goop, r=mshal
https://hg.mozilla.org/integration/mozilla-inbound/rev/c714a746f773
Remove a few references from .mk files, r=mshal
Assignee

Comment 23

2 years ago
Comment on attachment 8830460 [details]
Bug 1333826 - Remove SDK references from taskcluster beetmover,

Approval Request Comment
[Feature/Bug causing the regression]: not a regression
[User impact if declined]: we'll ship an unnecessary/unusable SDK with Firefox 53
[Is this code covered by automated tests?]: No
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]: No (just build config)
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: Build config issue could cause issues with release automation if that still expects to see an SDK. Releng (jlund) believes that this is all that's necessary.
Attachment #8830460 - Flags: approval-mozilla-aurora?

Updated

2 years ago
Blocks: 1335785
Comment on attachment 8830460 [details]
Bug 1333826 - Remove SDK references from taskcluster beetmover,

Remove unnecessary sdk. Aurora53+.
Attachment #8830460 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Updated

Last year
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.