Firefox totally unusable on large hg.mozilla.org page

RESOLVED DUPLICATE of bug 827937

Status

()

RESOLVED DUPLICATE of bug 827937
2 years ago
2 years ago

People

(Reporter: dvander, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

I accidentally tried viewing a large merge diff and Firefox totally collapsed. Mem usage immediately jumped to 2GB+, tab switches stopped working and other tabs stopped rendering. It was difficult to even open about:memory, but it looks like layout is allocating huge amounts of memory.

The content process crashed pretty quick and when I restored all tabs it immediately broke the UI again.

The URL is https://hg.mozilla.org/users/bschouten_mozilla.com/advanced-layers/rev/f88799660cf6

Note: Edge crashes almost immediately loading the page, but its UI is not affected anywhere near as badly as Firefox's. Nor are other tabs, or tab switching.
Chrome loads the page with about half the memory - the tab is unresponsive but other tabs and the UI work fine.
Summary: Firefox totally unusable on large page → Firefox totally unusable on large hg.mozilla.org page
This is a dupe of bug 827937 I believe?

Comment 3

2 years ago
(In reply to Ryan VanderMeulen [:RyanVM] from comment #2)
> This is a dupe of bug 827937 I believe?

I'm going to say so. The HTML on /rev/ pages hasn't changed much over the years. The only thing we've done somewhat recently is add highlighting. And the way pygments (the Python library for hightlighting) works, that could intensify resource usage via obscene inline CSS.

If anyone has suggestions for making Mercurial's HTML more efficient, I could upstream the changes.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 827937
You need to log in before you can comment on or make changes to this bug.