Closed Bug 13340 Opened 22 years ago Closed 22 years ago

[PP]Mac only, Slow to resize 3-pane window on older systems

Categories

(SeaMonkey :: MailNews: Message Display, defect, P3)

PowerPC
Mac System 8.5
defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: nbaca, Assigned: hangas)

References

Details

Build 1999090708M11: Mac 8.5.1

Overview: Launch Mail and try to resize the 3-pane window larger or smaller and
it doesn't resize.

Steps to reproduce:
1. Use an older Mac such as my PPC 8600/300 with 64 MB RAM or Esther's PPC
8500/250 96 MB RAM.
2. Launch Mail
3. Try to resize the 3-pane window larger or smaller

Actual Results: The 3-pane window does not resize.
Expected Results: I would have expected the window to be responsive and to
resize.

Workaround: Hold the mouse button down, resize the window and keep the mouse
button pressed until the 3-pane window responds. This may take up to 3 seconds.

Additional Information:
1. The 3-pane window resizes easily on my NT4 and Linux system
2. On the Mac I can easily resize the Navigator window, Compose window and the
Address Book window so it's only the 3-pane which exhibits the problem.
3. Peter's G3 system experiences a similar problem but it isn't as apparent
since it's a faster system.
QA Contact: lchiang → nbaca
Setting QA Contact to nbaca and adding lchiang to Cc: list.
Assignee: phil → evaughan
Reassigning to evaughan
Status: NEW → ASSIGNED
Target Milestone: M11
Blocks: 11091
(target milestone is M11 or M12 - add to mail beta tracking bug)
Target Milestone: M11 → M14
Currently the splitter does the very smallest amount of work it can. It only
redraws itself when you drag it. GFX needs to get faster and there are a lot of
people working on it. So I'm going going to move this way out.
Assignee: evaughan → hangas
Status: ASSIGNED → NEW
Target Milestone: M14 → M12
This appears to be a bug in one of the tables. Turns out one of the tables uses
a 1 pixel image for its background. This is sucking down major CPU.
Sounds like a layout bug to me.  Is there already a bug filed against layout on
this issue?  If not shall we send this to layout?
I'm pretty sure there is already a bug on layout involving 1 pixel gifs. I know
I'm cc'ed on it. Lemme see if I can dig up the number.
Status: NEW → ASSIGNED
Status: ASSIGNED → RESOLVED
Closed: 22 years ago
Resolution: --- → FIXED
Target Milestone: M12 → M11
This has been fixed by a layout checkin.  It was also fixed by a change to the
web page we were displaying.  Marking fixed.
Status: RESOLVED → VERIFIED
Build 1999110108M11: Mac 8.5.1
Verified Fixed. It's very easy and quick to resize the 3-pane window. Great!
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.