Closed Bug 1334287 Opened 4 years ago Closed 4 years ago

stylo: animation shorthand doesn't overwrite values of its longhands

Categories

(Core :: CSS Parsing and Computation, defect, P3)

defect

Tracking

()

RESOLVED FIXED
Tracking Status
firefox54 --- affected

People

(Reporter: dbaron, Unassigned)

References

(Depends on 1 open bug)

Details

Attachments

(1 file)

Attached file testcase
Here's a testcase that makes me suspicious of the mochitest results in stylo in general.

Basically, setting a shorthand property should overwrite all of the longhands in that declaration block.  In this testcase, setting the 'animation' shorthand doesn't change the value of the animation-timing-function property in that declaration block.

This should print "ease-out" on the first line and "ease" on the second line, but in stylo it prints "ease-out" on both.
Flags: needinfo?(xidorn+moz)
(Note that in Chrome it prints "initial" on the second line, which is equivalent in terms of what computed values it results in, since the initial value is "ease".)
This is not a general issue for shorthands. Shorthands like font, border, and margin should work. Animation stuff is mostly considered unimplemented at this moment, so I'm not very surprised that it doesn't work as expected.
Flags: needinfo?(xidorn+moz)
Summary: stylo: setting shorthand in specified style doesn't overwrite values for longhands → stylo: animation shorthand doesn't overwrite values of its longhands
Priority: -- → P3
Xidorn, could you please take time to confirm this?
The test case works fine now, I think your work of animation shorthand fixed this.
Flags: needinfo?(xidorn+moz)
Yeah, I think this has been fixed by that.
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(xidorn+moz)
Resolution: --- → FIXED
I mean, I also confirmed that this has been fixed :)
You need to log in before you can comment on or make changes to this bug.