Closed Bug 13344 Opened 20 years ago Closed 20 years ago

New browser windows generated by Manage Bookmarks too small

Categories

(Core :: Layout, defect, P3)

defect

Tracking

()

VERIFIED FIXED

People

(Reporter: cpratt, Assigned: davidm)

Details

(Whiteboard: 19991014 - verification still blocked by bug 11986)

Build ID: 1999090808
Platform: RH Linux 6, Windows NT

To reproduce:
- Launch apprunner
- Select Bookmarks | Manage Bookmarks
- Double-click on a bookmark to open that Web page

Result: A new window is generated correctly to open the Web page, but the window
is the same size and in the same position as the Manage Bookmarks window.

Expected result: A new window is generated which is both (a) the correct default
size for a new browser window, and (b) is visually offset from (ie not in the
exact same position as) the Manage Bookmarks window.
FWIW, the problem is even more pronounced when generating a new browser window
from the History window. Should I open another bug for that problem, or just
append it to this bug report?
Assignee: troy → trudelle
Who handles bookmarks?
Assignee: trudelle → don
I don't think there is a spec for this, but your steps on 4.x would cause the
URL to load in the top nav window.  Iff there weren't any open nav windows, then
it would open a new window with the sticky pref size and location, with no
regard for where the bookmarks window was.  This just sounds like the sticky
prefs are including non-nav windows.  reassigning to don for triage.
Assignee: don → davidm
I know why the window is so small so I'll fix it( and history). If bookmarks
should be using the topmost browser window file another bug and assign it to
slamm
QA Contact: petersen → claudius
Bookmarks - reassigning to claudius
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
fix checked.
windows generated from a Bookmarks double-click now appear at default size.
whether they should be off set is a different question. This is Mac and Linux b/c
bug 11986 is blocking verification on Windows.
Whiteboard: 19991014 - verification still blocked by bug 11986
Status: RESOLVED → VERIFIED
at last, we have verification on windows. VERIFIED fixed with 1999102008 build.
You need to log in before you can comment on or make changes to this bug.