Assertion failure: aInstanceSize == 0 || entry->GetClassSize() == aInstanceSize on simple WebRTC tests on try

RESOLVED FIXED in Firefox 55

Status

()

defect
P1
normal
Rank:
19
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: johannh, Assigned: pehrsons)

Tracking

unspecified
mozilla55
x86_64
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox55 fixed)

Details

Attachments

(2 attachments)

Running a simple test that triggers a WebRTC permission doorhanger (for bug 1331579) crashes debug builds on all platforms on try.

Log: https://treeherder.mozilla.org/logviewer.html#?job_id=72321177&repo=try&lineNumber=13999
Push on treeherder: https://treeherder.mozilla.org/#/jobs?repo=try&revision=2ed8467d8cd652df214c4cde4ea5bd5ca93f1f86&selectedJob=72496503

I've looked into this but failed to reproduce locally and have no clue why this error is even thrown on that code in the first place.
Assert at:
INFO - Assertion failure: aInstanceSize == 0 || entry->GetClassSize() == aInstanceSize (Mismatched sizes were recorded in the memory leak logging table. The usual cause of this is having a templated class that uses MOZ_COUNT_{C,D}TOR in the constructor or destructor, respectively. As a workaround, the MOZ_COUNT_{C,D}TOR calls can be moved to a non-templated base class.), at /home/worker/workspace/build/src/xpcom/base/nsTraceRefcnt.cpp:437
INFO - #01: NS_LogAddRef [xpcom/base/nsTraceRefcnt.cpp:1028]
INFO - #02: mozilla::media::Parent<mozilla::media::PMediaParent>::AddRef [dom/media/systemservices/MediaParent.h:50]

Jan-Ivar, can you take a look, it's a change you made 2 months ago for Bug 1312030.
Rank: 19
Component: WebRTC → WebRTC: Audio/Video
Flags: needinfo?(jib)
OS: Unspecified → Linux
Priority: -- → P1
Hardware: Unspecified → x86_64
Comment hidden (mozreview-request)
Assignee

Updated

2 years ago
Assignee: nobody → pehrson
Status: NEW → ASSIGNED
Flags: needinfo?(jib)
Assignee

Updated

2 years ago
Duplicate of this bug: 1320754

Comment 5

2 years ago
mozreview-review
Comment on attachment 8849147 [details]
Bug 1334421 - Don't use templated class for refcount macros in MediaParent.

https://reviewboard.mozilla.org/r/121976/#review123970

Thanks!
Attachment #8849147 - Flags: review?(jib) → review+
Are there tests we can re-enable thanks to this fix?
Flags: needinfo?(pehrson)
Assignee

Comment 7

2 years ago
(In reply to Florian Quèze [:florian] [:flo] from comment #6)
> Are there tests we can re-enable thanks to this fix?

Good question. I just ran into this when trying to reproduce bug 1320994. I'll see if I find something obvious.
Assignee

Comment 8

2 years ago
Searching for this bug in the tree gave this: http://searchfox.org/mozilla-central/rev/ee7cfd05d7d9f83b017dd54c2052a2ec19cbd48b/browser/base/content/test/general/browser_temporary_permissions.js#41

Something you want to act on Johann?


And there's this for bug 1320754: http://searchfox.org/mozilla-central/rev/ee7cfd05d7d9f83b017dd54c2052a2ec19cbd48b/browser/base/content/test/webrtc/browser.ini#15

I'll put up a patch for you Florian.
Flags: needinfo?(pehrson) → needinfo?(jhofmann)
(In reply to Andreas Pehrson [:pehrsons] (Telenor) from comment #8)
> Searching for this bug in the tree gave this:
> http://searchfox.org/mozilla-central/rev/
> ee7cfd05d7d9f83b017dd54c2052a2ec19cbd48b/browser/base/content/test/general/
> browser_temporary_permissions.js#41
> 
> Something you want to act on Johann?
> 

Yes, thanks for your work on this. I'll file a bug.
Flags: needinfo?(jhofmann)
Comment hidden (mozreview-request)

Comment 11

2 years ago
mozreview-review
Comment on attachment 8849491 [details]
Bug 1334421 - Re-enable test.

https://reviewboard.mozilla.org/r/122278/#review124842

Thanks!
Attachment #8849491 - Flags: review?(florian) → review+

Comment 12

2 years ago
We're sorry, Autoland could not rebase your commits for you automatically. Please manually rebase your commits and try again.

hg error in cmd: hg rebase -s 4b4e03e72312 -d f9333f409189: rebasing 383310:4b4e03e72312 "Bug 1334421 - Don't use templated class for refcount macros in MediaParent. r=jib"
rebasing 383311:b1c7f4df1f47 "Bug 1334421 - Re-enable test. r=florian" (tip)
merging browser/base/content/test/webrtc/browser.ini
warning: conflicts while merging browser/base/content/test/webrtc/browser.ini! (edit, then use 'hg resolve --mark')
unresolved conflicts (see hg resolve, then hg rebase --continue)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)

Comment 15

2 years ago
Pushed by pehrsons@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/cf0f994a49af
Don't use templated class for refcount macros in MediaParent. r=jib
https://hg.mozilla.org/integration/autoland/rev/2cb65b6a5a87
Re-enable test. r=florian

Comment 16

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/cf0f994a49af
https://hg.mozilla.org/mozilla-central/rev/2cb65b6a5a87
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
See Also: → 1350476
You need to log in before you can comment on or make changes to this bug.