Closed Bug 1334456 Opened 4 years ago Closed 4 years ago

Crash in OOM | large | mozalloc_abort | mozalloc_handle_oom | moz_xmalloc | mozilla::LookAndFeel::GetInt

Categories

(Core :: Graphics, defect)

52 Branch
x86
Windows
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1303094
Tracking Status
firefox51 --- unaffected
firefox52 --- affected
firefox53 --- unaffected
firefox54 --- unaffected

People

(Reporter: philipp, Unassigned)

References

Details

(Keywords: crash, Whiteboard: [gfx-noted])

Crash Data

This bug was filed from the Socorro interface and is 
report bp-1ab206b4-6cfd-44aa-a458-e22f62170127.
=============================================================
https://mozilla.github.io/stab-crashes/supergraph.html?s=OOM+|+large+|+mozalloc_abort+|+mozalloc_handle_oom+|+moz_xmalloc+|+mozilla%3A%3ALookAndFeel%3A%3AGetInt

these crash reports seem to be particular to firefox 52 & are probably related to bug 1299435
Version: 49 Branch → 52 Branch
maybe the signature [@ OOM | large | mozalloc_abort | mozalloc_handle_oom | moz_xmalloc | mozilla::DisplayListClipState::AutoClipMultiple::~AutoClipMultiple ] is related as well?
The LookAndFeel::GetInt part looks like the symbolizer run amok looking for a symbol for some anonymous code that just happened to be near there, but the real source of the pain is SkChunkAlloc::newBlock, which we are tracking in bug 1303094. In the interests of consolidating information for better tracking of this, I am duping this on to bug 1303094.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Whiteboard: [gfx-noted]
Duplicate of bug: 1303094
You need to log in before you can comment on or make changes to this bug.