Need to click on OK button twice to send out email containing characters not found in the selected Character Coding

RESOLVED DUPLICATE of bug 71709

Status

MailNews Core
Internationalization
RESOLVED DUPLICATE of bug 71709
16 years ago
10 years ago

People

(Reporter: Wonyong Koh, Assigned: nhottanscp)

Tracking

({intl})

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.9+) Gecko/20020325
BuildID:    2002032503

I use my name both in Korean and English in a mail signature file. The problem
with Mozilla Mail is that I cannot send a mail message in Character Coding
Western (ISO-8859-1). Clicking 'Send' button after composing a mail message in
English invokes a warning dialog box 'Confirm' saying:

'The message you composed contains characters not found in the selected
Character Coding, so your message may become unreadable after you send or save
it. To send or save it anyway, click OK. To return to the Composer window wher
you can choose a different Character Coding, click Cancel.'

Clicking 'OK' button invokes a new dialog box 'Sending Messages - (message
title)' saying

'Status: Assembling message...'

and make me wait forever. I have to click 'Cancel' to escape from it and the
mail message was not sent. 

The only characters not in Western (ISO-8859-1) Character Coding in the mail
message are my name in the signature, howver, I cannot send the message by
Mozilla Mail despite of the message 'To send or save it anyway, click OK.' 

In Netscape 6.1 Mail I can send the same message with no problem. Actually it is
the only reason that I cannot switch to Mozilla from Netscape.


Reproducible: Always
Steps to Reproduce:
1. Compose a mail message containing a character in Korean (EUC-KR).
2. Change Character Coding to Western (ISO-8859-1) under View menu.
3. Click 'Send' button to try to send the message.
4. Click 'OK' on 'Confirm' warning dialog box.

Actual Results:  Dialog box 'Sending Messages - (message title)' shows up and it
keeps waiting. I have to click 'Cancel'. The message was not sent.

Expected Results:  Mozilla should send a mail message if a user chooses 'to send
or save it anyway' by clicking 'OK'.

Comment 1

16 years ago
Confirmed the bug.
In case that both header and mail body contains illegal characters, you need to
click on OK button TWICE to send out the message. 
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: intl

Updated

16 years ago
Summary: Cannot send email containing characters not found in the selected Character Coding → Need to click on OK button twice to send out email containing characters not found in the selected Character Coding
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.2alpha
(Assignee)

Updated

16 years ago
Target Milestone: mozilla1.2alpha → ---

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 71709 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.