Error: "this.cloneScope is null in ExtensionItils.jsm:414:1" when leaving change event in popup

RESOLVED DUPLICATE of bug 1292701

Status

RESOLVED DUPLICATE of bug 1292701
2 years ago
3 months ago

People

(Reporter: admin, Unassigned)

Tracking

51 Branch

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

685.33 KB, application/x-zip-compressed
Details
(Reporter)

Description

2 years ago
Created attachment 8831244 [details]
example web extension for duplication

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20170118123726

Steps to reproduce:

1. Load Temporary Add-on
2. Click toolbar icon
3. Click upload icon
4. choose a file and click 'Open'


Actual results:

After choosing the file to upload, the 'change' event was triggered for the file input DOM element, then was handled by the popup script.  When exciting that function to send a message to the background script, the console showed the error 'this.cloneScope is null' and the function just exited.

This occurred on line 18 in popup.js.


Expected results:

The 'change' event would be called and handled by the popup script, then a message including the object url of the files will be sent to the background script message handler.

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1292701

Updated

3 months ago
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.