Intermittent TEST-UNEXPECTED-TIMEOUT | netwerk/test/unit/test_bug414122.js | Test timed out

RESOLVED DUPLICATE of bug 1321605

Status

()

Core
Networking
RESOLVED DUPLICATE of bug 1321605
a year ago
5 months ago

People

(Reporter: Treeherder Bug Filer, Unassigned)

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

This test just seems to take a very long time. It takes 21 seconds on my fairly fast machine - I imagine it would take a long time on the emulator. The logs seem to show that it stopped around half way through the test.
I don't really know what we should do here. Increase the timeout?
Flags: needinfo?(gbrown)
It is a long-running test, for sure.  In most recent Android Debug runs on mozilla-central, it completes in 130 to 150 seconds - a long time, but not close to the 300 second timeout.

I notice that other tests in that job took between 24 and 46 seconds:

[task 2017-01-27T17:54:54.612563Z] 17:54:54     INFO -  TEST-START | netwerk/test/unit/test_bug388281.js
[task 2017-01-27T17:55:26.276468Z] 17:55:26     INFO -  TEST-PASS | netwerk/test/unit/test_bug388281.js | took 31664ms
[task 2017-01-27T17:55:28.226596Z] 17:55:28     INFO -  TEST-START | netwerk/test/unit/test_bug396389.js
[task 2017-01-27T17:55:52.679401Z] 17:55:52     INFO -  TEST-PASS | netwerk/test/unit/test_bug396389.js | took 24453ms
[task 2017-01-27T17:55:54.868701Z] 17:55:54     INFO -  TEST-START | netwerk/test/unit/test_bug401564.js
[task 2017-01-27T17:56:36.983020Z] 17:56:36     INFO -  TEST-PASS | netwerk/test/unit/test_bug401564.js | took 42112ms
[task 2017-01-27T17:56:38.978281Z] 17:56:38     INFO -  TEST-START | netwerk/test/unit/test_bug411952.js
[task 2017-01-27T17:57:06.199603Z] 17:57:06     INFO -  TEST-PASS | netwerk/test/unit/test_bug411952.js | took 27221ms
[task 2017-01-27T17:57:08.604859Z] 17:57:08     INFO -  TEST-START | netwerk/test/unit/test_bug412945.js
[task 2017-01-27T17:57:54.632290Z] 17:57:54     INFO -  TEST-PASS | netwerk/test/unit/test_bug412945.js | took 46028ms
[task 2017-01-27T17:57:57.145109Z] 17:57:57     INFO -  TEST-START | netwerk/test/unit/test_bug414122.js
[task 2017-01-27T18:02:57.145821Z] 18:02:57  WARNING -  TEST-UNEXPECTED-TIMEOUT | netwerk/test/unit/test_bug414122.js | Test timed out
[task 2017-01-27T18:02:57.148931Z] 18:02:57     INFO -  TEST-INFO took 300000ms

Compare that to a recent log like https://public-artifacts.taskcluster.net/G6ydrqWRTbO-embpyB988g/0/public/logs/live_backing.log:

[task 2017-01-31T15:59:44.587216Z] 15:59:44     INFO -  TEST-START | netwerk/test/unit/test_bug388281.js
[task 2017-01-31T15:59:51.823528Z] 15:59:51     INFO -  TEST-PASS | netwerk/test/unit/test_bug388281.js | took 7237ms
[task 2017-01-31T15:59:53.106141Z] 15:59:53     INFO -  TEST-START | netwerk/test/unit/test_bug396389.js
[task 2017-01-31T15:59:59.442842Z] 15:59:59     INFO -  TEST-PASS | netwerk/test/unit/test_bug396389.js | took 6337ms
[task 2017-01-31T16:00:00.682753Z] 16:00:00     INFO -  TEST-START | netwerk/test/unit/test_bug401564.js
[task 2017-01-31T16:00:10.671471Z] 16:00:10     INFO -  TEST-PASS | netwerk/test/unit/test_bug401564.js | took 9989ms
[task 2017-01-31T16:00:11.862026Z] 16:00:11     INFO -  TEST-START | netwerk/test/unit/test_bug411952.js
[task 2017-01-31T16:00:18.000783Z] 16:00:18     INFO -  TEST-PASS | netwerk/test/unit/test_bug411952.js | took 6139ms
[task 2017-01-31T16:00:19.143342Z] 16:00:19     INFO -  TEST-START | netwerk/test/unit/test_bug412945.js
[task 2017-01-31T16:00:27.530146Z] 16:00:27     INFO -  TEST-PASS | netwerk/test/unit/test_bug412945.js | took 8387ms
[task 2017-01-31T16:00:28.619299Z] 16:00:28     INFO -  TEST-START | netwerk/test/unit/test_bug414122.js
[task 2017-01-31T16:02:59.209679Z] 16:02:59     INFO -  TEST-PASS | netwerk/test/unit/test_bug414122.js | took 150591ms

Notice how all of the tests run much slower in Comment 0 than we would normally expect? We see that occasionally, especially on Android jobs: Everything just runs very slowly, as though the aws host is not performing well.


I think you could safely dup this to bug 1321605.
Flags: needinfo?(gbrown)
Thanks Geoff!
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1321605

Comment 4

6 months ago
1 failures in 901 pushes (0.001 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* mozilla-inbound: 1

Platform breakdown:
* android-4-3-armv7-api15: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1334698&startday=2017-08-07&endday=2017-08-13&tree=all

Comment 5

5 months ago
1 failures in 885 pushes (0.001 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* autoland: 1

Platform breakdown:
* android-4-3-armv7-api16: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1334698&startday=2017-09-25&endday=2017-10-01&tree=all
You need to log in before you can comment on or make changes to this bug.