Can't cancel adding a boolean chart

REOPENED
Unassigned

Status

()

Bugzilla
Query/Bug List
REOPENED
17 years ago
8 years ago

People

(Reporter: neil@parkwaycc.co.uk, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

17 years ago
Using Communicator 4.79 or Mozilla Build ID: 2002032503
Steps to reproduce problem:
1. Turn on the insecure form submission warning
2. Click on "Or", "And" or "Add another boolean chart"
3. Click Cancel
4. Click "Submit Query"

Expected results: query performed

Actual results: query reloads, scrolled to chart
Assignee: endico → nobody

Comment 1

14 years ago
I don't understand the steps. There's no cancel button. Are you talking about
the form submission button? Does this still happen?

Feel free to re-open if this is still an issue.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

14 years ago
Updating URL to one which still shows the bug.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
(In reply to comment #1)
> I don't understand the steps. There's no cancel button. Are you talking about
> the form submission button? Does this still happen?
> 
> Feel free to re-open if this is still an issue.

I think what Neil is talking about is pressing "Cancel" when the browser warns
you about submitting a form. I haven't tried to reproduce because I don't know
how to switch the warning on...

Would it be a browser bug then?
(Reporter)

Comment 4

14 years ago
bugzilla.mozilla.org is on https which makes testing tricky, but to enable the
warning on an http bugzilla go to Preferences -> Privacy and Security -> SSL
(In reply to comment #4)
> bugzilla.mozilla.org is on https which makes testing tricky, but to enable the
> warning on an http bugzilla go to Preferences -> Privacy and Security -> SSL

With my browser, it turns out it's security.warn_submit_insecure at about:config :)

I can reproduce on landfill. The reason is the onclick-JavaScript in the Or, And
and Add buttons (document.forms[0].action='query.cgi#chart';
document.forms[0].method='POST') -- that modifies the Search button behaviour.

Updated

12 years ago
QA Contact: mattyt-bugzilla → default-qa
Assignee: nobody → query-and-buglist
OS: Windows 95 → All
Hardware: x86 → All
You need to log in before you can comment on or make changes to this bug.