Closed Bug 1335090 Opened 3 years ago Closed 3 years ago

firefox release versions can be configured to accept unsigned add-ons

Categories

(Toolkit :: Add-ons Manager, defect)

51 Branch
Unspecified
Linux
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1292444

People

(Reporter: boxcars, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20170126214052

Steps to reproduce:

https://groups.google.com/forum/#!msg/mozilla.support.firefox/KTtNSEnFe5g/XpCQ8qjPCwAJ shows a way to configure Firefox to accept unsigned extensions.
User Agent  Mozilla/5.0 (X11; Linux x86_64; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID    20170125094131

Hi Q,

I followed the instructions described in the google groups link and I wasn't able to make unsigned extension to work on the latest Firefox release, neither on Ubuntu or on Windows 10. For me, the extension that I am trying to install is blocked, as expected.

Are you able to install unsigned extensions on the latest Firefox release? If yes, could you please detail how you managed to do this?
Flags: needinfo?(boxcars)
I reported it based on posts in other threads which said it does work;  I haven't tried it myself yet.  I'll be happy to try, but I need a pointer to an unsigned add-on to test with.
Flags: needinfo?(boxcars)
Attached file popup.xpi
I've attached an unsigned addon, make sure to delete it after you're done :)
Flags: needinfo?(boxcars)
Thanks.  I'm running a Gentoo build of Firefox 51.0.  I think the post at Google has syntax errors, but with the following two files in place, I was able to install the unsigned popup.xpi.  

$ cat /usr/lib64/firefox/config.js
//
try {
  Components.utils.import("resource://gre/modules/addons/XPIProvider.jsm", {})
    .eval("SIGNED_TYPES.clear()");
}
catch(ex) {}



$ cat /usr/lib64/firefox/defaults/pref/local-prefs.js
pref("general.config.obscure_value", 0);
pref("general.config.filename", "config.js");
After untarring the Mozilla-supplied Firefox 51.0.1 in my home directory, I created ~/firefox/config.js and ~/firefox/defaults/pref/local-prefs.js with the same content as in comment 4, and was able to install popup.xpi.

In case it matters, the command I used to launch the Mozilla-supplied Firefox was 

$ ~/firefox/firefox -CreateProfile testingprofile && ~/firefox/firefox -P testingprofile

(to create a new profile named "testingprofile" then launch Firefox with that profile).
User Agent  Mozilla/5.0 (X11; Linux x86_64; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID    20161208153507

Thanks Q for all the help.

I was able to reproduce the issue on the latest Firefox release (51.0.1).
Status: UNCONFIRMED → NEW
Component: Untriaged → Add-ons Manager
Ever confirmed: true
Flags: needinfo?(boxcars)
OS: Unspecified → Linux
Product: Firefox → Toolkit
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1292444
You need to log in before you can comment on or make changes to this bug.