Allow extension overriden newtab to navigate to built-in new tab page

RESOLVED DUPLICATE of bug 1269456

Status

()

Toolkit
WebExtensions: Frontend
RESOLVED DUPLICATE of bug 1269456
4 months ago
3 months ago

People

(Reporter: wojwal, Unassigned)

Tracking

54 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 months ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/55.0.2883.87 Safari/537.36

Steps to reproduce:

I am testing "chrome_url_overrides" feature in WebExtension:

    "chrome_url_overrides": {
        "newtab": "newtab.html"
    }

Works fine. From inside overridden newtab page - in certain cases I'm trying to show standard firefox newtab page (about:newtab). What I tried:
 - window.location.href = 'about:newtab', or
 - chrome.tabs.update(tab.id, {url: 'about:newtab'});

I also tried chrome://browser/content/newtab/newTab.xhtml


Actual results:

It doesn't work - and shows error in browser console:

Unchecked lastError value: Error: Illegal URL: about:newtab

or

Unchecked lastError value: Error: Illegal URL: chrome://browser/content/newtab/newTab.xhtml


Expected results:

It should allow redirect to standard about:newtab page. 

Redirecting to "about:home" works fine - no issues... I guess it should be the same for about:newtab page.

There is no way to programatically unset "chrome_url_overrides" - and in my case I give an option to user to disable it - and this is my way to show standard newtab page. In all cases tiny "newtab.html" is loaded with just few lines of javascript that makes decision to load:
 - my own custom newtab page, or
 - standard browser newtab page
(Reporter)

Updated

4 months ago
Depends on: 1234150

Updated

4 months ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Follow-up to 1234150 - In overridden newtab allow to redirect to about:newtab → Allow extension overriden newtab to navigate to built-in new tab page

Updated

4 months ago
Blocks: 1234150
No longer depends on: 1234150

Comment 1

3 months ago
looking for dupe - kris
Flags: needinfo?(kmaglione+bmo)
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Flags: needinfo?(kmaglione+bmo)
Resolution: --- → DUPLICATE
Duplicate of bug: 1269456
You need to log in before you can comment on or make changes to this bug.