it eats away all attributes from some tags entered in a <textarea>

VERIFIED DUPLICATE of bug 99467

Status

()

Core
Layout: Form Controls
P3
normal
VERIFIED DUPLICATE of bug 99467
16 years ago
16 years ago

People

(Reporter: Alex Kapranoff, Assigned: kinmoz)

Tracking

({dataloss})

Trunk
x86
FreeBSD
dataloss
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:0.9.9) Gecko/20020320
BuildID:    00000000000

www.blogger.com let me adit my blog template (html) in browser. So when I submit
a large piece of text, all attributes from some tags I entered are gone. So that
"<a href=aaa><img src=aaa.gif></a>" turns into "<a><img></a>". That's very
weird. This could also be www.blogger.com problem, but it persists only in
Mozilla (IE, NN 4.77 work fine with the same texts entered!).

Reproducible: Sometimes
Steps to Reproduce:
1. have a blog at blogger.
2. try to edit template to a size > 10kb


Actual Results:  template is ruined. tags are structured ok, but their
attributes are blown away

Expected Results:  submit my html as I entered it

the guys at url I posted above (that's a forum thread) are saying that both
Galeon and K-meleon work as bad as original Mozilla.

Comment 1

16 years ago
I'd just like to mention that this isn't limited to FreeBSD; I'm seeing it in
win98 as well.
still persisting in 2002033109 in my own blog. though I'd like to point out that
my template, as saved on my computer, is only about 5k as a text file, and only
attributes from tags at the very end of the template have attributes removed.

Updated

16 years ago
QA Contact: madhur → tpreston
(Reporter)

Comment 2

16 years ago
I experience this weird behaviour in 1.0 release candidate.
Hardware: Other → PC
Target Milestone: --- → mozilla1.0
(Assignee)

Comment 3

16 years ago
Taking off rod's plate.

Can someone who is a blogger member, please attatch the complete HTML file used
for editing a blog template? Hopefully with sample content that exhibits the
problem?
Assignee: rods → kin
Keywords: dataloss, mozilla1.0
Priority: -- → P3
(Reporter)

Comment 4

16 years ago
I've investigated more into this bug i'm suffering from. I've attached a
trimmed-down version of html which causes grief. After looking into source
I can now reformulate the problem.

Mozilla eats away attributes from large html chunk which is inside textarea
element. The html-source is ok, but when I click the submit button, Mozilla
submits ruined data. Just load the attached html file and you'll see for
yourself. It both displays and submits incorrectly.

p.s. Thanks to Joaquin Blas for explanation about Target Milestone field!
Target Milestone: mozilla1.0 → ---
(Reporter)

Comment 5

16 years ago
Created attachment 80603 [details]
Sample html which demonstrates the problem.

No sensitive information inside as it's fully available on the web anyway.
Um... "<" and ">" need to be escaped in a textarea.... In this case they are
very obviously not.

*** This bug has been marked as a duplicate of 99467 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 7

16 years ago
Verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.