Thunderbird crash when opening some email after upgrade to 45.7.0

RESOLVED DUPLICATE of bug 1335638

Status

MailNews Core
Networking: IMAP
--
critical
RESOLVED DUPLICATE of bug 1335638
a year ago
a year ago

People

(Reporter: Andrea, Unassigned, NeedInfo)

Tracking

({crash})

x86_64
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [regression:TB45.7.0], crash signature)

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20170125172221

Steps to reproduce:

Open one email preview or in new tab or in new window.
Only for some email.
Only after upgrade to 45.7.0.
With same email and versione 45.6.0 no problem.


Actual results:

Thunderbird crash.

This is the gdb debug:
---
[New Thread 0x7fffdbdfe700 (LWP 31250)]
[New Thread 0x7fffc75ff700 (LWP 31281)]

Thread 1 "thunderbird" received signal SIGSEGV, Segmentation fault.
0x00007ffff09b8cda in ?? () from /usr/lib/thunderbird/libxul.so
----


Expected results:

Email showed correctly.
(Reporter)

Updated

a year ago
OS: Unspecified → Linux
Hardware: Unspecified → x86_64

Comment 1

a year ago
I have the same problem too, since I did the upgrade to the version of Thunderbird 45.7.0
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0
(In reply to Claudia from comment #1)
> I have the same problem too, since I did the upgrade to the version of
> Thunderbird 45.7.0
> Mozilla/5.0 (Windows NT 6.3; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0

Please post your crash ID.
see https://support.mozilla.org/en-US/kb/mozilla-crash-reporter#w_viewing-crash-reports
Flags: needinfo?(brunoclaudia09)
(Reporter)

Comment 3

a year ago
(In reply to Wayne Mery (:wsmwk, NI for questions) from comment #2)
> (In reply to Claudia from comment #1)
> > I have the same problem too, since I did the upgrade to the version of
> > Thunderbird 45.7.0
> > Mozilla/5.0 (Windows NT 6.3; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0
> 
> Please post your crash ID.
> see
> https://support.mozilla.org/en-US/kb/mozilla-crash-reporter#w_viewing-crash-
> reports

Hi Wayne,
these are my crash IDs related to this problem:
 - bp-4121cbdb-1a2b-41ab-8348-cd42d2170131
 - bp-f6d91769-aedb-4edb-b134-e27ae2170131
 - bp-a422f4ee-68b5-4183-9af8-7d7e62170131
 - bp-6d0dff30-2318-4689-9ae1-00f222170131
(In reply to Andrea from comment #0)
> User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:51.0) Gecko/20100101
> Firefox/51.0
> Build ID: 20170125172221
> 
> Steps to reproduce:
> 
> Open one email preview or in new tab or in new window.
> Only for some email.
> Only after upgrade to 45.7.0.
> With same email and versione 45.6.0 no problem.

Andrea,
For "some email", does it crash pretty reliably i.e. if you hit it again it will crash at least 50% of the time? If so, can you send me a sample?
Flags: needinfo?(fox91fox)
(In reply to Andrea from comment #3)
> ...
> these are my crash IDs related to this problem:
>  - bp-4121cbdb-1a2b-41ab-8348-cd42d2170131
SyncRunnable1<T>::Run

Does it also crash if you have started Thunderbird in safe mode?
https://support.mozilla.org/en-US/kb/safe-mode-thunderbird
#57 crash for 45.7.0
Severity: normal → critical
Crash Signature: [@ SyncRunnable1<T>::Run ]
Keywords: crash
Whiteboard: [regression:TB45.7.0]
(Reporter)

Comment 7

a year ago
(In reply to Wayne Mery (:wsmwk, NI for questions) from comment #5)
> (In reply to Andrea from comment #3)
> > ...
> > these are my crash IDs related to this problem:
> >  - bp-4121cbdb-1a2b-41ab-8348-cd42d2170131
> SyncRunnable1<T>::Run
> 
> Does it also crash if you have started Thunderbird in safe mode?
> https://support.mozilla.org/en-US/kb/safe-mode-thunderbird

Hi Wayne,
yes, also in safe mode.

If I open some email it crash 100% of time, but only when start rendering. If I open in new tab, it crash only when I focus in this new tab.

The error has been reported to me by one of my customers.
I copied the email and it also happens on my PC.
I have to ask if I can send you one.
This would make it public or remain to you?
Please try https://archive.mozilla.org/pub/thunderbird/nightly/2017/02/2017-02-04-03-02-04-comm-central/thunderbird-54.0a1.en-US.linux-x86_64.tar.bz2 and post your results, and any crash IDs.  It has a patch which the developer hopes will provide us greater insight.
(Reporter)

Comment 9

a year ago
(In reply to Wayne Mery (:wsmwk, NI for questions) from comment #8)
> Please try
> https://archive.mozilla.org/pub/thunderbird/nightly/2017/02/2017-02-04-03-02-
> 04-comm-central/thunderbird-54.0a1.en-US.linux-x86_64.tar.bz2 and post your
> results, and any crash IDs.  It has a patch which the developer hopes will
> provide us greater insight.

Hi Wayne,
I've tried this version but I have the same crash.
This is my crash ID: bp-ef6fbbe4-9790-4c4a-8b78-b2e932170206
Flags: needinfo?(fox91fox)
(In reply to Andrea from comment #9)
> (In reply to Wayne Mery (:wsmwk, NI for questions) from comment #8)
> > Please try
> > https://archive.mozilla.org/pub/thunderbird/nightly/2017/02/2017-02-04-03-02-
> > 04-comm-central/thunderbird-54.0a1.en-US.linux-x86_64.tar.bz2 and post your
> > results, and any crash IDs.  It has a patch which the developer hopes will
> > provide us greater insight.
> 
> Hi Wayne,
> I've tried this version but I have the same crash.
> This is my crash ID: bp-ef6fbbe4-9790-4c4a-8b78-b2e932170206

actually, fortunately it is a different signature,  [@ nsImapProtocol::SetupSinkProxy ]
Blocks: 1328814
Status: UNCONFIRMED → NEW
Crash Signature: [@ SyncRunnable1<T>::Run ] → [@ SyncRunnable1<T>::Run ] [@ nsImapProtocol::SetupSinkProxy ]
Component: Untriaged → Networking: IMAP
Ever confirmed: true
Product: Thunderbird → MailNews Core
Version: 45 Branch → 45

Comment 11

a year ago
(In reply to Wayne Mery (:wsmwk, NI for questions) from comment #10)
> > This is my crash ID: bp-ef6fbbe4-9790-4c4a-8b78-b2e932170206
> actually, fortunately it is a different signature,  [@
> nsImapProtocol::SetupSinkProxy ]
It all comes from the same root cause: in SetupSinkProxy() things are being set up without checking. Bug 1335638 has a patch to tighten the checking here.

Comment 12

a year ago
This was caused by bug 1328814 and will be fixed in 45.7.1 by backing out that bug.

Other versions will be fixed differently, see bug 1335638. I'm closing this now since we have four open bugs for the same issue which is well understood.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1335638
You need to log in before you can comment on or make changes to this bug.