Image is not shown because relative path starts with a space

RESOLVED DUPLICATE of bug 87894

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 87894
16 years ago
16 years ago

People

(Reporter: Daniel Mario Vega (Restore MNG Support --> #18574), Assigned: Marc Attinasi)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.9+) Gecko/20020324
BuildID:    2002032408

I don't know this is a bug. But it's something that works in MSIE, Nav 4.x and
Opera, but does not in Mozilla.

Whem you have an image with a relative path that (incorrectly) starts in space
(i.e. SRC = " /images/image.gif") the image is not shown.

This seems to be a bug on the web page, but Nav 4.x, MSIE and Opera loads the
image without problems. Mozilla does not.

I found this problem in this site:

http://www10.americanexpress.com/sif/cda/page/0,1641,11783,00.asp#fechas

Amazingly, if we right click over the broken image and select "View Image", the
image is shown correctly.

Reproducible: Always
Steps to Reproduce:
1. Go to the above URL or open the testcase

Actual Results:  The imagen is not loaded. A broken image appears

Expected Results:  The image should be loaded and displayed

I'll upload a striped testcase
Created attachment 76204 [details]
Reduced testcase

Comment 2

16 years ago
dup of bug 79929 i think, but that one was fixed almost 10 months ago..
And before that it was bug bug 24346.
Added comment in bug 79929 -> layout.
Assignee: new-network-bugs → attinasi
Component: Networking → Layout
QA Contact: benc → petersen

Comment 3

16 years ago
Confirming. 2002041603, WinxP.

FWIW: Bug 79929 was "PDT+, critical for 0.9.2"
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

16 years ago

*** This bug has been marked as a duplicate of 87894 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.