Closed Bug 1335482 Opened 4 years ago Closed 4 years ago

32-bit FF 51.0.1 - tab switching drops horribly after about 2 hours

Categories

(Firefox :: Untriaged, defect)

51 Branch
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: bugzilla.10.dggeorge, Unassigned, NeedInfo)

References

Details

Attachments

(1 file)

110.41 KB, application/x-7z-compressed
Details
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20170125094131

Steps to reproduce:

I've tried to NOT reproduce this, but it keeps happening!


Actual results:

On 1/30/2017 my office computer updated to 51.0.1, 32-bit.  After about two hours of use, the tab-switching became glacial.  Instead of instant, it would take 30 seconds or more to move to a new tab on which I'd clicked (granted, I have >30 open tabs, but I have always had this many).

When I clicked out of FF (the X in the upper right of the browser window) I noticed that I could not again start FF.  Opened the task manager, and the APPLICATION instance of FF was gone, as expected, but the PROCESS instance was still there.  Memory usage was about 1.0 gigs, which is less than it had been in earlier versions (computer is Win7 with 4gig of RAM).

I had to stop the FF from task manager's process tab, and then I could reopen it.

This cycle (slow tab switching after two hours, FF process remains open after x-ing out) repeated yesterday afternoon, then this morning.  Each time I get no more than 2-3 hours out of FF.


Expected results:

FF should remain responsive and tab switching instantaneous.

X-ing out of FF (click X in upper right corner) should terminate both the application and the process in task manager.
Multiprocess (e10s) has been expanded to many users with FF51.

Could you try with e10s disabled: https://wiki.mozilla.org/Electrolysis#Firefox_Release (restart to apply)
Flags: needinfo?(bugzilla.10.dggeorge)
I think they are disabled:

"Multiprocess Windows 	0/1 (Disabled by add-ons)"
It might be due to add-ons. Can you copy your add-ons list from the page about:support.
Adblock Plus	2.8.2	true	{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
Application Update Service Helper	1.0	true	aushelper@mozilla.org
Custom Tab Width	1.0.1.1-signed.1-signed	true	tab-width@design-noir.de
IE View	1.5.6.1-signed.1-signed	true	{6e84150a-d526-41f1-a480-a67d3fed910d}
Multi-process staged rollout	1.7	true	e10srollout@mozilla.org
oldbar	1.2.1-signed.1-signed	true	{46868735-c3fa-47ce-8ce7-cce51a66aceb}
Open With Google Chrome	49.0	true	{3cc6c6ba-654c-417e-a8af-6997ac388ae1}
Pocket	1.0.5	true	firefox@getpocket.com
Session Keeper	0.5.3.1-signed.1-signed	true	{6641C782-EC22-11DA-81F9-6FE8AF67805C}
Session Manager	0.8.1.13	true	{1280606b-2510-4fe0-97ef-9b5a22eafe30}
session-keepalive	0.2.3	true	jid1-zAt8odFFHQiNQA@jetpack
Web Compat	1.0	true	webcompat@mozilla.org
See Also: → 1326095
See Also: → 1334367
Flags: needinfo?(bugzilla.10.dggeorge)
Hi bugzilldg,

There are multiple reports regarding the browser being slow and one of the things they have in common is Adblock Plus. 

Could you please try to reproduce the issue with Adblock disabled and provide the results?
Flags: needinfo?(bugzilla.10.dggeorge)
I am comfortable that Adblock Plus is the cause of this issue.

I will quietly say here (don't flame me!)that I use a LOT of tabs.  At this instant I have 32 tabs open in my browser, and the number tends to increase as the day goes on.  I have an add-on that opens all the tabs when I restart (that is, tabs open when I shut FF down, are present when I start it again, although the pages don't get visited until I click into them).

I am currently using about 1gig of memory for FF.  Just disabled ABP and doing so had no effect on memory usage.  But will now close browser, restart (ABP still disabled) and see what effect that has.
Maybe not the full answer to this bug report, but if you need an adblocker, you can use uBlock Origin instead of ABP, which is known to have better perf than ABP.
Reopened FF with disabled ABP and it was using 240 MB with one tab visited.  Bit by bit it's been creeping up (Facebook seems to really push it).  I have perhaps opened 10 tabs and I'm now up to 740 MB.  That's less than the gig that it had been using, but not too too much less.  I'll keep my eye on it, but that's the report for now.
Had meant to comment three days ago that, after disabling ABP and substituting uBlock Origin, my browser ran better than it had all week.  Probably better than it had run in six+ months (it started crashing a lot during summer 2016, although I'd been using ABP long before that).

Fact is that 51.0.1 and ABP don't "play nice with each other," because my browser performance really dropped after updating to that version.
(In reply to bugzilldg from comment #9)

Could you confirm whether you have been affected by Bug 1326095? (Are you having ghost-windows with AdBlock Plus enabled? (at the time of experiencing the issue) If so, how many? It would be good if you would attach the about:memory report)
(In reply to marcino245 from comment #10)
> (In reply to bugzilldg from comment #9)
> 
> Could you confirm whether you have been affected by Bug 1326095? (Are you
> having ghost-windows with AdBlock Plus enabled? (at the time of experiencing
> the issue) If so, how many? It would be good if you would attach the
> about:memory report)

I read that bug report, and my past - not present - symptoms were reasonably similar.

Starting in July 2016 (rough guess) my browser began crashing a lot more than ever before.  Sometimes, for some number of minutes prior to the crash, if I'd click to another open tab, the contents of the prior tab (the one from which I'd clicked) would still be displayed on my screen.  Sometimes I could "paint" the tab correctly by moving the mouse around (tab window would render when swept by mouse); sometimes minimizing the browser than clicking into it would fix things.

In the roughly day and a half I've used uBlock Origin instead of ABP, I have not seen this happen.
Based on Comment 11 from the reporter, changing status to RESOLVED WORKSFORME.
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Flags: needinfo?(bugzilla.10.dggeorge)
Resolution: --- → WORKSFORME
Attached file logs.7z
I have been using Firefox Developer Edition + a several add-ons pack since two weeks, and I have had no problems with it, I have been leaving the browser open for the night with several tabs open, and next day in the morning I have been continuing the browsing session, the browser has been running fast, low memory and bugs free. But today in the morning, after leaving Firefox for the night yesterday, the tab switching has dropped horribly, switching a tab takes several seconds, it sometimes takes 5 seconds to switch to a different tab, and meantime, a rotating circle animation is being showed in the tab's blank webpage content. It has began to happen after auto-update to 53.0a2 20170305004006.
Hey marcino245,

Thanks for the report!

I looked at your about:support and your about:memory reports, and nothing jumped out at me. You don't _appear_ to be suffering from a memory leak, which was my first guess at what you were seeing.

Would it be possible for you to install another add-on, from: https://perf-html.io/

This is the Gecko Profiler Add-on, and acts like a flight-recorder to help us understand what is happening during the problem.

If you install that add-on, and get yourself into this state again, switch your tabs a few times to show the tab switch spinner, and then click on the icon in the toolbar and choose "Capture Profile". This will dump the information into a new tab.

Then, click on the "Share" button in the top-right of the profile. Read the privacy warning carefully (your performance profile might contain information about the add-ons you're running and the pages you're on, along with some machine-specific information that should have already been in the about:support information you sent us). That should give you a URL that you can post in here.

I am very eager to look at such a profile to help us understand what you're seeing here.
Flags: needinfo?(marcino245)
I wanted to provide an update here.

Today I separately started https://bugzilla.mozilla.org/show_bug.cgi?id=1346335 - asking if it's possible that the current release of LinkedIn, which is the thing I most use at work, is the cause of my woes.

I started a brand new profile in Firefox today, and have deliberately not used LinkedIn, and the browser is performing wonderfully, for longer than it's done in more than a month.

I cannot say if the improvement is because of the new profile, or because of the LinkedIn avoidance, or both.

On Monday I will start using LinkedIn as heavily as I normally do and see what happens.  I should add though that in my first 30 minutes on the computer today, no LinkedIn but no new profile either at that point, the browser was already sluggish.  So, hoping, with a bit of reason, that the new profile cured my ills.

By the way, in Comment 11 above, I said that uBlock origin may have solved my problem.  It didn't.  When resuming normal browser use, the browser had the same problems, even as I closed the largest blocking lists.  The list closures didn't much affect the memory usages, and they didn't make the browser longer-lasting, or more stable.
(In reply to Mike Conley (:mconley) (Catching up on reviews and needinfos) from comment #14)

If the issue will reappear, I'll try that, but as for now, after restarting the browser and running a several hours session the issue has not reappeared yet.

As for more about the restarting the browser: within a long 48h browser session, the browser has been becoming more and more sluggish until it has became so sluggish, choppy and jerky (switching between tabs, watching videos, UI lagging) that  it forced me to kill firefox.exe process in the task manager and restart the browser.

And I have a question: some of mozilla developers suggest using Cleopatra Profiler to get performance profile, and some suggest using Gecko Profiler, what's the difference and which one is better?
Fixing a typo: it forced = it has forced.
(In reply to marcino245 from comment #16)
> (In reply to Mike Conley (:mconley) (Catching up on reviews and needinfos)
> from comment #14)
> 
> And I have a question: some of mozilla developers suggest using Cleopatra
> Profiler to get performance profile, and some suggest using Gecko Profiler,
> what's the difference and which one is better?

Sure, I can answer that.

They're actually two halves of the same tool.

The Gecko Profiler add-on is the half that gathers the performance data from the browser, and then opens that performance data in a tool called Cleopatra. Cleopatra is a tool that we use for visualizing and analyzing that kind of performance data.

So in order to gather one, you need to get the add-on. Once you've gathered the profile, you can share it from within Cleopatra, and we will view it within Cleopatra.

Let me know if you have more questions, and I'll do my best to answer.
You need to log in before you can comment on or make changes to this bug.