Closed Bug 1335574 Opened 4 years ago Closed 4 years ago

stylo: handle legacy CSS font size keywords and HTML font size values

Categories

(Core :: CSS Parsing and Computation, defect, P2)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1341775

People

(Reporter: manishearth, Unassigned)

References

Details

bug 1330041 adds basic support for presentation attributes in Stylo. However, it just uses Servo's support for legacy font-size keywords (medium, x-large, numeric values, etc).

Servo does a straightforward mapping to constants. This is not what we do in Gecko; the table is a bit more complicated[1], and depends on the "base size" of the font[2]. We'll eventually want to copy this code over to Servo or call into it. The spec probably needs to be changed as well.




 [1]: http://searchfox.org/mozilla-central/rev/4e0c5c460318fb9ef7d92b129ac095ce04bc4795/layout/style/nsRuleNode.cpp#3090-3150
 [2]: http://searchfox.org/mozilla-central/rev/4e0c5c460318fb9ef7d92b129ac095ce04bc4795/layout/style/nsRuleNode.cpp#3431-3432
Priority: -- → P2
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1341775
You need to log in before you can comment on or make changes to this bug.