'Inspect Element with Firebug' not working with e10s enabled

RESOLVED INVALID

Status

()

Firefox
Developer Tools: Inspector
P2
enhancement
RESOLVED INVALID
a year ago
a year ago

People

(Reporter: steve, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [specification][type:bug])

(Reporter)

Description

a year ago
What did you do?
================
Hover over an object on a page, right-click-->inspect object. (like a input field)

What happened?
==============
This toggles the inspector window on or off and when it toggles it on, it does not go to the html object - instead it's at the default body tag.

What should have happened?
==========================
It should not toggle the inspector window -- it should turn it on if it was off, but not toggle it off. It should also drill down to the object within the html.

Is there anything else we should know?
======================================
FireBug worked correctly. But you probably hear this a lot.
Component: General → Developer Tools: Inspector
Product: Mozilla Developer Network → Firefox
Need some more information to investigate.

Can you provide a URL to reproduce the issue (and specify which element you are trying to inspect)?
Which version of firefox are you using? On which operating system?

Thanks
Flags: needinfo?(steve)
(Reporter)

Comment 2

a year ago
Firefox 51.0 (64-bit)
Windows 7 Ultimate, SP 1

Hmmm. While duplicating this in noticed that my right-click menu has two options: Inspect Element (Q) and Inspect Element with Firebug. I've always use the latter and it is broken. I just tried the first Inspect option and it appears to work. Maybe I just need to uninstall Firebug.

I do have another issue but I'll make a separate report.
Honza: can you investigate this bug report? Looks like the Inspect element link from Firebug is not selecting the right element in Devtools.
Flags: needinfo?(steve) → needinfo?(odvarko)
I did some quick tests about this, and it looks like clicking on "Inspect Element With Firebug" simply opens the devtools. If you happen to be on the inspector, then the body will be selected. You also get the popup about Firebug being integrated with DevTools, but you can dismiss it.

Looking at the Firebug code, the stack that leads to opening devtools is:
- BrowserOverlay.js::startFirebug
- BrowserOverlay.js::showMultiprocessNotification
- BrowserOverlay.js::toggleDevTools
- BrowserOverlay.js::showToolbox

And in the end we simply call DevTools.gDevTools.showToolbox(target);

From what I can see here we never actually tried to forward the selected node from the Firebug inspect command to Devtools. We simply open Devtools instead of Firebug.

I'll keep the ni? for Honza and will add two questions:
- do you think it's possible to forward the node to select to the Devtools inspector?
- otherwise should we disable this menuitem since the current behavior is a bit confusing?
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P2
Honza, we should file an equivalent issue in the Firebug repository to be fixed since this lies outside of our devtools.
Severity: enhancement → normal
Status: NEW → UNCONFIRMED
Ever confirmed: false
Priority: P2 → --
And close this bug when we have that done and possibly fix.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P2
Severity: normal → enhancement
New issue created in the official Firebug issue list:
https://github.com/firebug/firebug/issues/8077

I don't know what priority this has.
Do note that there is plenty of issue reported recently.

Honza
Flags: needinfo?(odvarko)
Summary: Inspect Object not working → 'Inspect Element with Firebug' not working with e10s enabled
I don't think this bug is actionable in Bugzilla as the resolution is being tracked in https://github.com/firebug/firebug/issues/8077

Closing.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.