Closed Bug 1335986 Opened 3 years ago Closed 2 years ago

There is something that triggers style flush (especially flushing animation?) on Android x86.

Categories

(Core :: DOM: Animation, defect)

x86
Android
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla58
Tracking Status
firefox58 --- fixed

People

(Reporter: hiro, Assigned: hiro)

References

Details

Attachments

(1 file)

From bug 1326306 comment 4

I did check that all of the recent failures happened in the first test case.   One interesting thing is that some of failures received 7 restyles instead of 6 restyles.  I am convinced that one restyle comes from creating a thumbnail (See bug 1276170).  I guess the other one is the root cause of this recent failure.  I think there was a change on Android that causes flush style after the document has been finished to be loaded.

There seems to be something that causes style flush when a page initially loaded.  This bug is for tracking it down.
Assignee: nobody → nchen
Status: NEW → ASSIGNED
For the record, that test started to failing on aurora too. The beginning is:

https://treeherder.mozilla.org/#/jobs?repo=mozilla-aurora&revision=d8d335074d5c896ccacce5e302baae193e62dbaf
Flags: needinfo?(hikezoe)
Stealing. 
https://treeherder.mozilla.org/#/jobs?repo=try&revision=66b935eb5680e54b5d8d26938dbb47225ebf9ccf

Now test_restyles.html runs in content window (bug 1379515), so it should not receive unexpected animation restyles in chrome window any more.
Assignee: nchen → hikezoe
Component: General → DOM: Animation
Flags: needinfo?(hikezoe)
Product: Firefox for Android → Core
(In reply to Hiroyuki Ikezoe (:hiro) from comment #2)
> Stealing. 
> https://treeherder.mozilla.org/#/
> jobs?repo=try&revision=66b935eb5680e54b5d8d26938dbb47225ebf9ccf

There are some oranges on the try, but all of them are bug 1363957.
Also note that on our CI, mochitest-plains don't run on Android x86.  I don't know the reason though.
Comment on attachment 8923615 [details]
Bug 1335986 - Run test_restyles.html on Android.

https://reviewboard.mozilla.org/r/194746/#review199790
Attachment #8923615 - Flags: review?(bbirtles) → review+
Thanks for the quick review!
Pushed by hikezoe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8d224ee53eda
Run test_restyles.html on Android. r=birtles
https://hg.mozilla.org/mozilla-central/rev/8d224ee53eda
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla58
You need to log in before you can comment on or make changes to this bug.