drag over a personal toolbar folder: menu should close after the drop

VERIFIED FIXED in mozilla1.0

Status

VERIFIED FIXED
17 years ago
14 years ago

People

(Reporter: p_ch, Assigned: p_ch)

Tracking

Trunk
mozilla1.0
x86
Windows ME
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt2])

(Assignee)

Description

17 years ago
windows build 2002 03 16 03

steps to reproduce:
1. drag the location bar proxy icon over a folder in the PT
2. drop it

Current result: menu still open
Expected result: menu closes after a short time necessary to indicate that the
DND performed correctly

Comment: after DND, subfolders close as expected
(Assignee)

Updated

17 years ago
Blocks: 133604

Comment 1

17 years ago
nominating for nsbeta1, though closing on mouseOut might be enough for now.
Keywords: nsbeta1

Comment 2

17 years ago
nsbeta1+/adt2 per Nav triage team
Keywords: nsbeta1 → nsbeta1+
Whiteboard: [adt2]
Target Milestone: --- → mozilla1.0

Comment 3

17 years ago
*** Bug 134867 has been marked as a duplicate of this bug. ***

Comment 4

17 years ago
Chris Lyon: I'm glad you caught the similarity between this bug and 134867, but
calling it a dupe was a mistake.

This bug has a terrible subject.  It will be impossible to find via keyword
queries.  Bug 134867 has a much better subject.  If they were dupes, I say that
the other bug's subject may reduce the likelihood of duplicates.

And regarding the bug itself, 134867 is NOT a dupe of this bug.  True, it may
depend on this bug for a possible workaround, but it's not a dupe.  134867 has
nothing to do with dropping on the PT.  Instead, it concerns the fact that
*many* PT folders pop open and stay open when casually dragging an unrelated
object across Mozilla.

Comment 5

17 years ago
-> pierre, who has a fix for these issues. Thanks Pierre!
Assignee: blaker → pierrechanial
(Assignee)

Updated

17 years ago
Depends on: 139471
(Assignee)

Updated

17 years ago
No longer blocks: 133604
(Assignee)

Comment 6

17 years ago
*** Bug 141183 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 7

17 years ago
*** Bug 142066 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

17 years ago
Summary: DND in a folder in PT: menu should close after the drop → drag over a personal toolbar folder: menu should close after the drop
(Assignee)

Updated

17 years ago
Blocks: 133604

Comment 8

17 years ago
This bug is fixed in 2002052306 1.0 RC3
(Assignee)

Comment 9

17 years ago
fixed by the checkin of bug 139471
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
appears to work fine on win2k using 2003.02.19 comm trunk.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.