PNG image incorrectly displayed after scrolling away, the scrolling back

RESOLVED DUPLICATE of bug 121230

Status

()

Core
ImageLib
--
trivial
RESOLVED DUPLICATE of bug 121230
16 years ago
16 years ago

People

(Reporter: Neil Pearce, Assigned: Stuart Parmenter)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.9) Gecko/20020311
BuildID:    

http://www.neilpearce.com/rastan/index.html
contains a PNG title image.
Once the page has been displayed, if I scroll
the page down so the image is off the screen,
then scroll back, the PNG image is "not quite"
right. If I then press the left mouse button
over the image, it is suddenly displayed
correctly. it is then clear some scan lines were
not being displayed correctly.

Reproducible: Always
Steps to Reproduce:
1. load http:/www.neilpearce.com/rastan/index.html
2. scroll down, so the neilpearce.com image is off screen
3. scroll back up
4. the image "looks ok", but move cursor over image
and press left mouse button
5. the image "improves". it is clear there was a
slight decredation beforehand.

Actual Results:  image is displayed correctly. there is only a slight
difference between the "looks ok" and "correct"
image. but clearly, something is amiss

Expected Results:  displayed the PNG 100% correctly when scrolling back
(Reporter)

Comment 1

16 years ago
If you scroll the image off the screen, then scroll back
*slowly* so the image if displayed step by step, in repeated
upwards movements then the effect is more apparant.
->ImageLib
Assignee: attinasi → pavlov
Component: Layout → ImageLib
QA Contact: petersen → tpreston
(Reporter)

Comment 3

16 years ago
I notice it doesn't seem to do this with Netscape 6.2,
which I thought uses the same rendering engine?

Comment 4

16 years ago
Also happens on this url: http://www.glandium.org/ on win xp with build
2002032603 when you are in 800x600 (because if you are in a greater resolution
no need to scroll) on the big bottom left png ("glandium III processor") and
also on the center png image on the right of the main frame ("machin inside").

I can confirm this. (and would change the status to CONFIRMED if I could)
Can someone with right to do this please change the status. ?

I'm using WinXP and build 2002032708.

It happens on all the PNG images I have tried.
I first found it on the "official" test page for PNG images.

Select the Debug menu
Navigate to Verification
Select PNG images.

The browser will open http://www.libpng.org/pub/png/png-MagnoliaAlpha.html

scroll to the bottom .. scroll up again.
The image will now be shown garbled.

I have have further information to what is going on here.
I find that if I scroll really slowly up so that only 1 line of pixels is
updated I get a almost perfectly flipped picture (it's probably almost perfectly
flipped because i did not scroll slow enough .. had I done so it might have been
perfectly flipped)

If I scroll fast using the mouse wheel I get big chunks as the browser updated
several lines each time.

It seems that when the picture is updated the part that is updated is updated
correctly but it as mapped from the wrong position in the image.

So if it was to show the last line it would instead updated it as the first.
The second last would be the second first.

If it should update 3 lines f.x. in a 100 line image , where it needed to show
line 98 , 99 and 100 it would show line 1 , 2 and 3 in that (correct) order.
It will not be totally oposite and show line 3 , 2 and 1.

So it seems to map the point to read from reversed from what it should be.

The same thing will happen if you scroll down instead of up.
It does not happen if you scroll sideways.

And as described earlier a left click updates the image correctly, and I have
found so does a rightclick .. or at least it does on the page i described above.

However if you rightclick on the image this page links to :
ftp://swrinde.nde.swri.edu/pub/png/images/png/Alpha/MagnoliaAlpha.png
( warning that picture is 3.2 MB )
, it does NOT update correctly AND you discover something else .. the place
where the rightclick menu have been covering the image is also not updated
correctly.

I have also found that while the image is loading this does not seem to happen
.. or if it does it is corrrected so fast (because other updates to the image
other than scrolling seems to work) that I can't tell.

AND if you stop the page and thus the image from loading (press the stop button)
then the image WILL update correctly when you scroll.

Very strange...

On another subject the transparency verification test also displays bugs .. but
that must be related to some other bug .. I'll search for that later.
I'm just surprised that people don't check the verification demo's when they are
sort of built in (because they have a menu item)

I don't think this PNG bug is a trivial one .. it totally corrupts PNG images
and that is a very serious bug IMO.
I'm inclined to put it as a 1.0 blocker because 1.0 should reflect a quality
product .. a solid base to develop further on - and it can't be if PNG display
is corrupted this seriously.

If anyone agrees I sugest we change the severity status and target milestone to
reflect this.

In any case .. fix this ASAP.

Comment 6

16 years ago
*** This bug has been confirmed by popular vote. ***
Status: UNCONFIRMED → NEW
Ever confirmed: true
I reseached this bug for several hours today and found some new info on it .. I
also found that this is a duplicate of 121230 and I will thus post my findings there

Comment 8

16 years ago

*** This bug has been marked as a duplicate of 121230 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.