Closed Bug 1336391 Opened 3 years ago Closed 3 years ago

Crash in nsFormFillController::StartSearch

Categories

(Toolkit :: Form Manager, defect, P1, critical)

Unspecified
All
defect

Tracking

()

RESOLVED FIXED
Iteration:
54.2 - Feb 20
Tracking Status
firefox52 --- unaffected
firefox53 --- fixed
firefox54 --- fixed

People

(Reporter: jseward, Assigned: MattN)

References

(Blocks 1 open bug)

Details

(Keywords: crash, Whiteboard: [FxPrivacy] )

Crash Data

This bug was filed from the Socorro interface and is 
report bp-c052d1c7-30b5-4edd-9c41-dd5ff2170203.
=============================================================

This is ranked #7 in the Windows crashes for Aurora 20170202004013.

I don't know what Component to use for this.
Assignee: nobody → MattN+bmo
Blocks: 1304224
Status: NEW → ASSIGNED
Component: Untriaged → Form Manager
Product: Core → Toolkit
Based on the timing this was probably caused by https://hg.mozilla.org/releases/mozilla-aurora/rev/0d5fd88afc55 (bug 1334026) which just went to Beta.

I thought I search for this signature the other day just in case and didn't see anything wrong but maybe that was before this started.
Blocks: 1334026
OS: Windows 10 → All
It seems like the problem is mLoginManager being null at `mLoginManager->AutoCompleteSearchAsync(…)` which means that the added:
>    if (!mLoginManager) {
>      mLoginManager = do_GetService("@mozilla.org/login-manager;1");
>    }

is failing sometimes.
I'm fixing this in bug 1330111 attachment 8830641 [details] since that also needs to get uplifted.
Depends on: 1330111
Bug 1334026 is backed out of 52 for now, updating status.
Iteration: --- → 54.2 - Feb 20
Whiteboard: [FxPrivacy]
Priority: -- → P1
Flags: qe-verify?
Flags: qe-verify? → qe-verify-
You need to log in before you can comment on or make changes to this bug.