Select input with thousands of options became sensitively slower

RESOLVED DUPLICATE of bug 1118086

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 1118086
10 months ago
5 months ago

People

(Reporter: Luca Pasquini, Unassigned)

Tracking

51 Branch
x86_64
Windows 10
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 months ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20170125094131

Steps to reproduce:

Fill a select input with few thousands of options and open the dropdown


Actual results:

Opening the select dropdown needs some time.

The wait time is proportional to the amount of options, starting from half a second with ~1000 records to 2-3 seconds with ~8000 records (using an i5 with Windows 10).


Expected results:

Opening the select dropdown should need almost no time, regardless of the amount of options (just like older versions)
(Reporter)

Updated

10 months ago
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64
Thanks for filing this bug. This is already being tracked by bug 1118086. I'll close this one as a duplicate of that bug, but thank you for filing this bug and for letting us know.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1118086
You need to log in before you can comment on or make changes to this bug.