bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Can't find anything useful searching for options_ui

RESOLVED FIXED

Status

Developer Documentation
Add-ons
RESOLVED FIXED
2 years ago
a year ago

People

(Reporter: Mindaugas <LA-MJ>, Unassigned)

Tracking

(Depends on: 1 bug)

Details

(Reporter)

Description

2 years ago
Expected top result:
https://developer.mozilla.org/en-US/Add-ons/WebExtensions/manifest.json/options_ui

Actual results with addons tag selected: https://developer.mozilla.org/en-US/search?q=options_ui&topic=api&topic=addons&topic=css&topic=html&topic=js&topic=apps&topic=webdev

Not a single page related to WebExtensions on the first result page
We had this problem with Google results before, because of the .json in the URL matching a robots.txt include pattern.
Status: UNCONFIRMED → NEW
Ever confirmed: true
The problem is with the MDN site search, not with Google results.

If you expand the search to "All Topics", it is the first result:

https://developer.mozilla.org/en-US/search?q=options_ui&none=none

Site search is driven by tags, and the options_ui page doesn't have any. I think it would make sense to appear under "Add-ons and Extensions", which would require tagging the page with Add-ons, Extensions, or Plugins
Component: Search → Add-ons
Product: Mozilla Developer Network → Developer Documentation
Depends on: 963811
Thanks for filing this LA-MJ. I've added some tags for all the manifest keys, so they should show up if you select "Add-ons & Extensions" in Topics.

I think the default topics should be expanded to include Add-ons (and maybe WebExtensions too) I've filed bug 1337461 for this.

Basing search entirely on tagging is not ideal though: tagging is a pain to do and is easy to forget or get wrong. We have a pretty consistent site structure, and if search included everything under "/Add-ons" when you selected "Add-ons" in Topics, this would all just work.

Florian linked above to bug 963811, which covers this, especially bug 963811, comment 4.
Adding tags and bug 1337461 fixed this.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.