Session restore does not auto-load tabs

RESOLVED DUPLICATE of bug 1334875

Status

()

Firefox
Session Restore
RESOLVED DUPLICATE of bug 1334875
10 months ago
9 months ago

People

(Reporter: mounir, Unassigned)

Tracking

({nightly-community, regression, regressionwindow-wanted})

Trunk
nightly-community, regression, regressionwindow-wanted
Points:
---

Firefox Tracking Flags

(firefox54 fixed)

Details

(Reporter)

Description

10 months ago
STR:
1. open Firefox Nightly
2. Wait for all tabs to show up
3. Click on a random tab

Actual result: URL shows up but no content
Expected result: URL shows up and content starts loading

Note: pressing enter/reloading works in most case, unless the tab has a #anchor

Application Basics
------------------

Name: Firefox
Version: 54.0a1
Build ID: 20170204110423
Update Channel: nightly
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:54.0) Gecko/20100101 Firefox/54.0
OS: Linux 4.4.0-59-generic
Multiprocess Windows: 4/4 (Enabled by default)
Safe Mode: false

Updated

10 months ago
Keywords: nightly-community

Comment 1

10 months ago
I can reproduce that with some of my pinned tabs as well although not systematically

Updated

10 months ago
Keywords: regression, regressionwindow-wanted

Comment 2

10 months ago
I am seeing the problem just now in Firefox53.0a2.
When the problem occurred, Browser console shows the following error.

NS_ERROR_FAILURE: Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsISerializationHelper.nsISerializationHelper] 1 Utils.jsm:135


The restored tab is empty, F5 does nothing. The tabs of restored are completely broken.
Page can be loaded in new tab.

Reproducible: none
Comment hidden (obsolete)

Comment 4

10 months ago
Seems regressed by Bug 1307736.

And maybe duplication of Bug 1334875

Updated

10 months ago
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1334875

Comment 6

9 months ago
FF54 was fixed in bug 1334875. Mark 54 fixed.
status-firefox54: affected → fixed
You need to log in before you can comment on or make changes to this bug.