Closed Bug 1336884 Opened 5 years ago Closed 3 years ago

Codemotion page is not visible on Firefox browser

Categories

(Web Compatibility :: Mobile, defect, P3)

Firefox 50
All
Android
defect

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: kritika.thakur81, Unassigned)

References

()

Details

(Whiteboard: [contactready])

Attachments

(1 file)

Attached image prob1.png
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/55.0.2883.87 Safari/537.36

Steps to reproduce:

I went through this link (http://speaker.codemotionworld.com/c4p.php?c=gestione_call4paper), I cannot scroll page on mobile Firefox browser,Unable to fill input fields.


Actual results:

I cannot scroll page on mobile Firefox browser,Unable to fill input fields.


Expected results:

It should scroll and zoom the page. However it is working fine in other browsers.
It looks like the user needs to log in to see the page. Any chance you can save the page and (if it doesn't contain any private information) attach it to the bug?
OS: Unspecified → Android
Hardware: Unspecified → All
(Flagging needinfo for comment 1)
Flags: needinfo?(kritika.thakur81)
It has personal data.It would be great if you can create account/register yourself.It has same issue I cannot scroll left.
(In reply to Kritika Maheshwari from comment #3)
> It has personal data.It would be great if you can create account/register
> yourself.It has same issue I cannot scroll right.
The page seems to do this intentionally. The CSS on the page has this [1]:
  body { overflow-y: scroll; overflow-x: hidden;}
which prevents horizontal scrolling.

[1] http://speaker.codemotionworld.com/layout/c4p/css/main.css?t=60  (line 81)
Status: UNCONFIRMED → NEW
Component: Graphics, Panning and Zooming → Mobile
Ever confirmed: true
Flags: needinfo?(kritika.thakur81)
Product: Firefox for Android → Tech Evangelism
Version: 50 Branch → Firefox 50
Whiteboard: [needscontact]
1. this site is not secure. registration process under http.
2. It has dark patterns in registration with mandatory pseudo-options


So I created a dummy account.

The site contains:

        <meta name="viewport" content="width=device-width, initial-scale=1">

and indeed body contains

body {
	overflow-y: scroll;
	overflow-x: hidden;
}


and 
#main {
	display: inline-block;
	width: 870px;
	padding: 20px 40px 100px;
	position: relative;
	left: 20%;
	margin-left: -350px;
}



I think it's yet another instance of Bug 1336346. I tested in Chrome on Android.
where Chrome let the people scroll even with a overflow-x: hidden;

Also it doesn't seem to have a specific version for Mobile.
Depends on: 1336346
If we decide to contact them, we just need to ask them to remove the 
	overflow-x: hidden;

They have a contact form at 
http://www.codemotionworld.com/#contact

There are also on twitter but not interacting with users
https://twitter.com/CodemotionWorld/with_replies
Whiteboard: [needscontact] → [contactready]
Priority: -- → P3
Flags: needinfo?(oana.arbuzov)
The issue is still reproducible. 

[Tested with:]
Browser / Version: Firefox Nightly 64.0a1 (2018-09-20)
Operating System: Google Pixel (Android 9) - 1080 x 1920 pixels (~441 ppi pixel density), Samsung Galaxy S7 Edge (Android 8.0.0) - Resolution 1440 x 2560 pixels (~534 ppi pixel density)

Since they did not manage to fix the issue on their side, I will close this as Wontfix.
If anyone reaches them in any way please inform them.
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(oana.arbuzov)
Resolution: --- → WONTFIX
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.