Closed Bug 1336902 Opened 3 years ago Closed 3 years ago

Thread running non-stop in WindowGamepadMessageLoopOnceRunnable::Run()

Categories

(Core :: DOM: Device Interfaces, defect)

51 Branch
x86_64
Windows 10
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1324592

People

(Reporter: ag.moz, Unassigned)

Details

(Keywords: regression)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/51.0.2704.79 Safari/537.36 Edge/14.14393

Steps to reproduce:

Start Firefox (51.0.1 64-bit - public build)
Wait for idle

This did not happen in the 51.0.


Actual results:

One core continuously runs:

>	win32u.dll!NtUserPeekMessage()	Unknown
 	user32.dll!PeekMessageW()	Unknown
 	xul.dll!`anonymous namespace'::WindowGamepadMessageLoopOnceRunnable::Run() Line 974	C++
 	xul.dll!nsThread::ProcessNextEvent(bool aMayWait, bool * aResult) Line 1067	C++
 	xul.dll!NS_ProcessNextEvent(nsIThread * aThread, bool aMayWait) Line 311	C++
 	xul.dll!mozilla::ipc::MessagePumpForNonMainThreads::Run(base::MessagePump::Delegate * aDelegate) Line 338	C++
 	xul.dll!MessageLoop::RunHandler() Line 226	C++
 	xul.dll!MessageLoop::Run() Line 206	C++
 	xul.dll!nsThread::ThreadFunc(void * aArg) Line 467	C++
 	nss3.dll!_PR_NativeRunThread(void * arg) Line 419	C
 	nss3.dll!pr_root(void * arg) Line 96	C
 	ucrtbase.dll!_o__realloc_base()	Unknown
 	kernel32.dll!BaseThreadInitThunk()	Unknown
 	ntdll.dll!RtlUserThreadStart()	Unknown



Expected results:

Firefox should end in idle state.
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64
That sounds similar to bug 1318839.

Any idea Michael?
Component: Untriaged → DOM: Device Interfaces
Flags: needinfo?(cleu)
Keywords: regression
Product: Firefox → Core
I think this issue has been fixed in bug1324592.

So it will be fix in aurora.

Should we uplift this patch to beta as well?
Flags: needinfo?(cleu)
ag.moz, could you install Aurora and confirm it's fixed on your side, please.
https://www.mozilla.org/en-US/firefox/developer/all/
Flags: needinfo?(ag.moz)
(In reply to Loic from comment #3)
> ag.moz, could you install Aurora and confirm it's fixed on your side, please.
> https://www.mozilla.org/en-US/firefox/developer/all/

Sorry for the delay.

Installed the latest Developer Edition, and it idles properly with a Xbox 360 Controller plugged in.
Flags: needinfo?(ag.moz)
Ty. Let's dupe it. If it's back, reopen the bug.
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1324592
You need to log in before you can comment on or make changes to this bug.