Broken test-packages.json file from TC on archive.mozilla.org which references target.*.zip files

VERIFIED FIXED

Status

Release Engineering
General Automation
--
major
VERIFIED FIXED
10 months ago
10 months ago

People

(Reporter: whimboo, Assigned: mtabara)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

As noticed the recent test-packages.json files on archive.mozilla.org are busted for Linux Nightly builds:

https://archive.mozilla.org/pub/firefox/nightly/2017/02/2017-02-05-11-05-39-mozilla-central/firefox-54.0a1.en-US.linux-i686.test_packages.json

All of them are containing references to a target.*.zip achive, which do not exist on archive.mozilla.org.

I assume that this is a fallout from the build Nightly on TC work on bug 1267422 and following. We seem to simply copy the artifacts over to archive.mozilla.org, and modify the file name. But actually miss to adjust the listed test packages in the json file.

Can anyone from Releng please have a look? 

This blocks any fx-ui tests for Nightlies, but also don't allow others to use test packages to run tests.
Flags: needinfo?(bugspam.Callek)

Updated

10 months ago
Blocks: 1336927

Updated

10 months ago
Flags: needinfo?(bugspam.Callek)
(Assignee)

Comment 1

10 months ago
Created attachment 8834255 [details] [review]
Bug 1336926 - fix broken test-packages.json. r=aki
Assignee: nobody → mtabara
Status: NEW → ASSIGNED
Attachment #8834255 - Flags: review?(aki)

Comment 2

10 months ago
Comment on attachment 8834255 [details] [review]
Bug 1336926 - fix broken test-packages.json. r=aki

Waiting on manifest changes; let me know if you need help with that.
Attachment #8834255 - Flags: review?(aki)
(Assignee)

Comment 3

10 months ago
https://github.com/mozilla-releng/beetmoverscript/pull/46
Bug 1336926 - fix broken test-packages.json. r=aki
(Assignee)

Updated

10 months ago
Component: General Automation → Release Automation
QA Contact: catlee → rail
Component: Release Automation → General Automation
QA Contact: rail → catlee
(Assignee)

Comment 4

10 months ago
https://hg.mozilla.org/build/puppet/rev/efbeba6743d8
Bug 1336926 - bump beetmoverscript version in beetmoverworker.r=trivial
(Assignee)

Comment 5

10 months ago
https://hg.mozilla.org/build/puppet/rev/30776a1ef9a5
Bug 1336926 - add missing var in beetmoverworker script_config. r=trivial
(Assignee)

Comment 6

10 months ago
Retriggered https://tools.taskcluster.net/task-group-inspector/#/DkilAL_fQcaDk9Ff0A-B-g/dOJLbG3aSw2Sd14CAr0uvQ to reupload the build artifacts from http://archive.mozilla.org/pub/firefox/nightly/2017/02/2017-02-08-11-02-48-mozilla-central/ and more specifically http://archive.mozilla.org/pub/firefox/nightly/2017/02/2017-02-08-11-02-48-mozilla-central/firefox-54.0a1.en-US.linux-i686.test_packages.json.

The file now looks good:

{
    "cppunittest": [
        "firefox-54.0a1.en-US.linux-i686.common.tests.zip",
        "firefox-54.0a1.en-US.linux-i686.cppunittest.tests.zip"
    ],
    "talos": [
        "firefox-54.0a1.en-US.linux-i686.common.tests.zip",
        "firefox-54.0a1.en-US.linux-i686.talos.tests.zip"
    ],
    "reftest": [
        "firefox-54.0a1.en-US.linux-i686.common.tests.zip",
        "firefox-54.0a1.en-US.linux-i686.reftest.tests.zip"
    ],
    "xpcshell": [
        "firefox-54.0a1.en-US.linux-i686.common.tests.zip",
        "firefox-54.0a1.en-US.linux-i686.xpcshell.tests.zip"
    ],
    "mochitest": [
        "firefox-54.0a1.en-US.linux-i686.common.tests.zip",
        "firefox-54.0a1.en-US.linux-i686.mochitest.tests.zip"
    ],
    "mozbase": [
        "firefox-54.0a1.en-US.linux-i686.common.tests.zip"
    ],
    "jittest": [
        "firefox-54.0a1.en-US.linux-i686.common.tests.zip",
        "jsshell-linux-i686.zip"
    ],
    "common": [
        "firefox-54.0a1.en-US.linux-i686.common.tests.zip"
    ],
    "gtest": [
        "firefox-54.0a1.en-US.linux-i686.common.tests.zip",
        "firefox-54.0a1.en-US.linux-i686.gtest.tests.zip"
    ],
    "web-platform": [
        "firefox-54.0a1.en-US.linux-i686.common.tests.zip",
        "firefox-54.0a1.en-US.linux-i686.web-platform.tests.zip"
    ]
}

I double checked the S3 behind archive.m.o and it looks good. Due to caching and CDNs, it might need a few until it shows correctly under archive.m.o though.
Status: ASSIGNED → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → FIXED
Thanks for fixing this. It looks all fine now.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.