Closed Bug 1337174 Opened 3 years ago Closed 2 years ago

Implement `@media (width < 600px)` syntax from MQ Level 4

Categories

(Core :: CSS Parsing and Computation, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1422225

People

(Reporter: mtanalin, Unassigned)

References

(Blocks 1 open bug, )

Details

(Keywords: dev-doc-needed)

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID: 20170206004003

Steps to reproduce:

Media Queries Level 4 spec [1] specifies a math-like syntax for defining adjacent ranges in CSS:

    @media (300px <= width < 600px) {}

The previously available `min-width: 300px` syntax corresponds to `width >= 300px` (with the inevitable "or equal" part) and has no equivalent for `width < 600px` (without the "or equal" part).

Tab Atkins from CSSWG considers the feature stable ("stable as a rock") enough to be implemented [2].

[1] https://drafts.csswg.org/mediaqueries/#mq-range-context
[2] https://lists.w3.org/Archives/Public/www-style/2017Feb/0036.html
Component: Untriaged → CSS Parsing and Computation
Product: Firefox → Core
Summary: Implement `@media (width < 300px)` syntax from MQ Level 4 → Implement `@media (width < 600px)` syntax from MQ Level 4
Priority: -- → P3
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1422225
You need to log in before you can comment on or make changes to this bug.