Misconfigured ALSA (or setup with no audio hardware) can cause crashes in cubeb when trying to play audio

RESOLVED DUPLICATE of bug 1337805

Status

()

Core
Audio/Video: cubeb
P3
normal
Rank:
35
RESOLVED DUPLICATE of bug 1337805
a year ago
a year ago

People

(Reporter: Martin Husemann, Assigned: kinetik)

Tracking

51 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

a year ago
There was a bogus freeing of an uninitialized cond var in an error path if cubeb failed to initialize alsa. This caused firefox to dump core for me when web sites tried to play audio.

I reported the issue upstream and it was quickly fixed:

https://github.com/kinetiknz/cubeb/commit/0c2b114e5b9436d17680afe5bc45a10eb43163
90

Depending on pthread immplementations this could have caused less visible corruption in other systems, but the "no working audio" setup probably is quite exceptional when using a browser.
P3 because IIRC we don't officially support alsa anymore. Should be an easy fix however.
Rank: 35
Priority: -- → P3
(Assignee)

Comment 2

a year ago
Created attachment 8836810 [details] [diff] [review]
p1 - Update libcubeb to afad5aae.
Attachment #8836810 - Flags: review?(padenot)
(Assignee)

Updated

a year ago
Assignee: nobody → kinetik
Status: NEW → ASSIGNED
(Assignee)

Updated

a year ago
Summary: Misconfiugred alsa (or setup with no audio hardware) can cause crashes in cubeb when trying to play audio → Misconfigured ALSA (or setup with no audio hardware) can cause crashes in cubeb when trying to play audio
Attachment #8836810 - Flags: review?(padenot) → review+
Comment on attachment 8836810 [details] [diff] [review]
p1 - Update libcubeb to afad5aae.

Matthew, Gecko's copy is already at 21e96a, handled in bug 1337805. We did this bump so we could have :chunmin OSX multichannel code in, and this includes the alsa fix.
Attachment #8836810 - Flags: review+
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1337805
You need to log in before you can comment on or make changes to this bug.