Closed Bug 1337356 Opened 6 years ago Closed 1 year ago

Cannot undo in task tab or today pane

Categories

(Calendar :: Tasks, defect, P2)

Lightning 4.7.7

Tracking

(thunderbird_esr78 wontfix)

VERIFIED FIXED
91 Branch
Tracking Status
thunderbird_esr78 --- wontfix

People

(Reporter: psychonaut, Assigned: lasana)

References

Details

(Keywords: dataloss)

Attachments

(2 files)

After deleting an event or task from the task tab or the today pane, the Undo command in the Edit window remains deactivated.  Please allow event/task deletions to be undone.
Wow I am surprised this feature was never added or even reported beforehand. Maybe I haven't found the duplicate bug though. Confirming.
Severity: normal → major
Status: UNCONFIRMED → NEW
Component: General → Tasks
Ever confirmed: true
Priority: -- → P2
Summary: Undo task or event deletion → Cannot undo in task tab or today pane
Duplicate of this bug: 1354693
(In reply to Philipp Kewisch [:Fallen] from comment #1)
> Wow I am surprised this feature was never added or even reported beforehand.
> Maybe I haven't found the duplicate bug though. Confirming.

There was Bug 258258 - Add "REDO" AND "UNDO" facility to calendar. But apparently it did not go far enough?

There is https://support.mozilla.org/en-US/questions/1172143
Keywords: dataloss
See Also: → 1256327
Duplicate of this bug: 1369445
Hit by this bug again, today.  I thought I was in a spreadsheet, but the window focus was really on Thunderbird's Tasks tab.  I started entering a number with a decimal in it, and my task was deleted with no warning!

What happened also exposes another bug (for which I'll open a ticket):  the decimal key, if Num Lock is on, is not a delete key, but Thunderbird Lightning treats it as such.  Even pressing the keyboard's main period key (the key with the ">" and "." symbols) deletes a task if the task is highlighted!
Opened Mozilla Bugzilla 1409560 for the `period key is not a delete key` issue.

But re-looking at this cannot-undo-delete bug, I see it was opened against Lightning 4.7.7.  I'm currently using Lightning 5.4.3.  Should another bug be opened for that version?
Assignee: nobody → mschroeder
Status: NEW → ASSIGNED
Assignee: mschroeder → nobody
Status: ASSIGNED → NEW
Assignee: nobody → lasana

Wow, I did not realize this Bugzilla ticket was still open. But yes, I see in my Thunderbird 78.10.1 that one can still not undo a task deletion.

Thanks, Magnus, for pointing out the code module and assigning this ticket to Lasana. (Good luck, Lasana.)

Status: NEW → ASSIGNED

It appears that adding an event does not enable the undo menu either.

This was accomplished by making the CalTransactionManager class aware of
batch transactions which can result in peeking of the transaction stack
to return null.

Target Milestone: --- → 91 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/0f4f406ddf3e
Enable undo/redo for event creation and deletion. r=darktrojan

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/fbb43934b5ae
followup - fix linting. rs=eslint DONTBUILD
Flags: needinfo?(lasana)

I forgot to rebase after Geoff removed some of the lightning references.

Flags: needinfo?(lasana)

Also takes advantage of saveAndCloseItemDialog() new behaviour of
waiting for the dialog to be closed.

Geoff - please include in next push to fix tests.

Duplicate of this bug: 1256327

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/d5d385497178
Follow up: update lightning references in test. r=mkmelin

Duplicate of this bug: 1498843
See Also: → 1428254

Verified using Thunderbird 91.0b4 on Fedora Linux.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.