[Linux] Scrollbar behaviour incorrect regarding to GTK3 way (equivalent to having it in hover mode permanently)

RESOLVED DUPLICATE of bug 1147847

Status

()

Core
Widget: Gtk
P4
normal
RESOLVED DUPLICATE of bug 1147847
a year ago
a year ago

People

(Reporter: Bruno Pagani, Unassigned)

Tracking

53 Branch
All
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: tpi:+)

Attachments

(6 attachments)

(Reporter)

Description

a year ago
Created attachment 8834396 [details]
GDK_SCALE=2

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID: 20170111030235

Steps to reproduce:

Ran Firefox with GDK_SCALE=2.


Actual results:

Scrollbar is way too large.


Expected results:

Scrollbar should have the normal size. I can get this with GDK_SCALE=1 + GDK_DPI_SCALE=2, but then all the others application behave strangely.
(Reporter)

Comment 1

a year ago
Created attachment 8834397 [details]
GDK_SCALE=1 GDK_DPI_SCALE=2
(Reporter)

Comment 2

a year ago
This is with GTK Arc theme by the way, but it’s even more ugly with Breeze theme for instance, can add screenshots for that if needed.
(Reporter)

Updated

a year ago
Summary: [Linux] Scrollbar to large on HiDPI → [Linux] Scrollbar too large on HiDPI
(Reporter)

Comment 3

a year ago
I should also add that it works OK in Thunderbird, but this one being still GTK2 it’s scaled through layout.css.devPixelsPerPx=2.
(Reporter)

Updated

a year ago
OS: Unspecified → Linux
Hardware: Unspecified → All

Updated

a year ago
Component: Untriaged → Widget: Gtk
Product: Firefox → Core
Priority: -- → P4
Whiteboard: tpi:+
GDK_SCALE is intended to affect the size of the scrollbar.

Compare the scrollbar in gtk3-demo with GDK_SCALE=2 in the environment.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX
(Reporter)

Comment 5

a year ago
If I’m reporting this issue, it’s because every other GTK3 application in my desktop do not behave like this. But it seems I’ve failed to precise this earlier.

Thanks for pointing gtk3-demo, from that one I’ve been able to tell exactly what’s wrong with Firefox and not with any other application: apparently, the behaviour of scrollbars in GTK3 app is different depending on whether the cursor is over them or not, and whether there has been some cursor move or scrolling action recently. In any other GTK3:

– the scroll bar has no background by default (so there is only the variable length part) and is slim;
– the scrollbar fades away when there hasn’t be any move recently (either cursor or scrolling);
– the scrollbar gets a larger size and a full background when hovered.

But in Firefox, it’s in permanently hovered mode.

I’ll attach three screenshots right after to show this behaviour in gtk3-demo.
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---
(Reporter)

Comment 6

a year ago
Created attachment 8837070 [details]
Scrollbar has fade away.
(Reporter)

Comment 7

a year ago
Created attachment 8837072 [details]
Scrollbar in normal mode.
(Reporter)

Comment 8

a year ago
Created attachment 8837073 [details]
Scrollbar is fading away.
(Reporter)

Comment 9

a year ago
Created attachment 8837074 [details]
Scrollbar in hover mode (like is Firefox permanently)
(Reporter)

Comment 10

a year ago
So, I should say this is probably not an HiDPI error anymore, but a more general one. I’ve changed the title accordingly.
Summary: [Linux] Scrollbar too large on HiDPI → [Linux] Scrollbar behaviour incorrect regarding to GTK3 way (equivalent to having it in hover mode permanently)
Bug 1147847 tracks that.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year agoa year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1147847
You need to log in before you can comment on or make changes to this bug.