Java Plugin not installed when JRE already present

VERIFIED WORKSFORME

Status

SeaMonkey
Installer
VERIFIED WORKSFORME
16 years ago
a year ago

People

(Reporter: Sven M. Resch, Assigned: dveditz)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 obsolete attachment)

(Reporter)

Description

16 years ago
Have Win2k with a JRE1.3.1 already installed on in D:\programs directory.
Installed Moz0.99 into the same D:\programs directory and everything but the
Java plugin seemed to intstall correctly.
Although I've followed directions and copied the NPxxxx.dll files from the jre
to the moz plugin dirs and everything works... it would be nice for users with
novice computer skill levels for this feature to be installed properly and
already work by default.

Comment 1

16 years ago
please see http://gemal.dk/mozilla/java.html on getting Java working

Comment 2

16 years ago
this is duplicate of bug 100393

*** This bug has been marked as a duplicate of 100393 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 3

16 years ago
is this really a dupe?
I think think bug is about the mozilla installer not copying the NPOJI610.dll
file to the plugin directory.

to reproduce:

install jre
install mozilla

expected:
java works in mozilla

actual:
java doesn't work in mozilla due to missing NPOJI610.dll file in plugins
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Reporter)

Comment 4

16 years ago
Not sure as to exactly which dll's are required so I copied NPJava11.dll, 
NPJava12.dll, NPJava131.dll, NPJava32.dll and NPOJI600.dll from my JRE into the 
moz Plugins directory.

BTW, 
- The only dll that was in the Plugin directory after the install was one named 
npnul32.dll.
- I downloaded & used the full .exe installer as opposed to the .zip version.
- From reading the messages related to the bug that was marked as the 
duplicate... I was wondering if my problem might in fact had to do with the 
directory structure that I have as opposed to anything else.


*** This bug has been marked as a duplicate of 75651 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE

Comment 6

16 years ago
nope. this bug is about the mozilla installer not detecting JRE and making JRE
work  with mozilla
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 7

16 years ago
I confirm. To reproduce:
1. install JRE (fx Sun Java2 JRE v1.4.0
2. install Mozilla
3. Java not working in mozilla (should be)

the reason is of cause the leak of the npoji610.dll file in the plugins
directory. So the question if "should mozilla auto copy the file"

please see bug 134147 about a more general bug about the detection of already
installed supported plugins.
Severity: major → normal
Status: UNCONFIRMED → NEW
Ever confirmed: true
There are 2 ways to fix this bug.
a) Mozilla detects the plugin in the installation folder
b) The installer detects the plugin and copy it to mozilla plugins folder

My duping was and is correct but if you want also solution b)....

Comment 9

16 years ago
*** Bug 140367 has been marked as a duplicate of this bug. ***

Comment 10

16 years ago
I think that bug 133282 is a fix for that bug:
Popular plugins are now scanned in their installation folder

so is this FIXED ?

Comment 11

16 years ago
fixed by bug 133282
Status: NEW → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → WORKSFORME

Comment 12

16 years ago
bravo= worksforme  rc2 build
Status: RESOLVED → VERIFIED
QA Contact: bugzilla → gbush
Product: Browser → Seamonkey
Created attachment 8830301 [details] [diff] [review]
Fix memset sizes in rtt_filter.cc

MozReview-Commit-ID: 3pnTseY4k2M
Attachment #8830301 - Flags: review?(dminor)
Comment on attachment 8830301 [details] [diff] [review]
Fix memset sizes in rtt_filter.cc

Wrong bug number
Attachment #8830301 - Attachment is obsolete: true
Attachment #8830301 - Flags: review?(dminor)
You need to log in before you can comment on or make changes to this bug.