Closed Bug 1337728 Opened 3 years ago Closed 3 years ago

Reenable browser_forgetAPI_EME_forgetThisSite.js for e10s

Categories

(Testing :: General, defect, P1)

Version 3
defect

Tracking

(firefox54 fixed)

RESOLVED FIXED
mozilla54
Iteration:
54.3 - Mar 6
Tracking Status
firefox54 --- fixed

People

(Reporter: gkrizsanits, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [e10s-multi:+])

No description provided.
Blocks: 1315042
Whiteboard: [e10s-multi:+]
I couldn't reproduce this locally until I figured out that the cause of the failure is in an earlier test. Leaving only browser_eme.js and browser_forgetAPI_EME_forgetThisSite.js in the browser.ini and running them together always reproduce the failure.

What I don't get about browser_eme.js is that it passes the test while the session load fails [1]. I could not track it down exactly why does it fail but we hit this line: [2]

And then after the test passes (it expect no media keys anyway) running browser_forgetAPI_EME_forgetThisSite.js fails with:

35 INFO Console message: MediaKeySystemAccess::GetKeySystemStatus(org.w3.clearkey) result=available msg=''
[GMP 10836] WARNING: GMPGetAPI call failed trying to construct decryptor.: file c:/development/mozilla-central/dom/media/gmp/GMPContentChild.cpp, line 104
Hit MOZ_CRASH(aborting because of MsgProcessingError) at c:/development/mozilla-central/dom/media/gmp/GMPChild.cpp:417

[1] http://searchfox.org/mozilla-central/rev/b1044cf7c2000c3e75e8181e893236a940c8b6d2/browser/components/contextualidentity/test/browser/browser_eme.js#168

[2] http://searchfox.org/mozilla-central/rev/b1044cf7c2000c3e75e8181e893236a940c8b6d2/dom/media/gmp/widevine-adapter/WidevineDecryptor.cpp#354
Looks like this is the line that's stopping us from initializing the CDM: http://searchfox.org/mozilla-central/source/dom/media/gmp/widevine-adapter/WidevineAdapter.cpp#87
Pushed by gkrizsanits@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/c8f9ec4046ee
Reenable browser_forgetAPI_EME_forgetThisSite.js. r=me
https://hg.mozilla.org/mozilla-central/rev/c8f9ec4046ee
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla54
Iteration: --- → 54.3 - Mar 6
Priority: -- → P1
You need to log in before you can comment on or make changes to this bug.