Closed Bug 1338027 Opened 3 years ago Closed 3 years ago

[RTL] Fix paddings in the linear tabs layout for RTL

Categories

(Firefox for Android :: Theme and Visual Design, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 54
Tracking Status
firefox53 --- fixed
firefox54 --- fixed

People

(Reporter: twointofive, Assigned: twointofive)

References

(Blocks 1 open bug)

Details

Attachments

(3 files)

Some of the paddings in the linear tabs layout aren't set for RTL: there's an outer padding on the thumbnail side that doesn't get reversed in RTL (shows up as too much padding on the left and too little padding on the right in the screenshot), and there are different paddings on the two sides of the title that don't get reversed in RTL (though it's hard to tell visually).
Screenshot of LTR and RTL with the patch.
Comment on attachment 8835260 [details]
Bug 1338027 - Fix RTL padding in the linear tabs layout.

https://reviewboard.mozilla.org/r/110968/#review112314

LGTM! Added Max, who's been working on making Fennec support RTL, as second reviewer.
Attachment #8835260 - Flags: review?(s.kaspari) → review+
Comment on attachment 8835260 [details]
Bug 1338027 - Fix RTL padding in the linear tabs layout.

https://reviewboard.mozilla.org/r/110968/#review112676

LGTM! Thanks, Tom. :)
Attachment #8835260 - Flags: review?(max) → review+
Pushed by twointofive@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/101c4902811d
Fix RTL padding in the linear tabs layout. r=maliu,sebastian
https://hg.mozilla.org/mozilla-central/rev/101c4902811d
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 54
Seems to be fixed on latest Nightly, according to Tom's last screenshot.
Max, RTL is landing in 53, right?  Should I request uplift to aurora for this and bug 1337897?
Flags: needinfo?(max)
Tom, sure do. Both patch have no risk on uplift, please request uplift to aurora. Thank you.
Flags: needinfo?(max)
Comment on attachment 8835260 [details]
Bug 1338027 - Fix RTL padding in the linear tabs layout.

Approval Request Comment
[Feature/Bug causing the regression]: RTL for fennec
[User impact if declined]: in RTL mode some of the padding on the tabs tray in portrait mode will be wrong (see the first screenshot).
[Is this code covered by automated tests?]: No.
[Has the fix been verified in Nightly?]: Yes.
[Needs manual test from QE? If yes, steps to reproduce]: No I guess. I'm never sure under what conditions I'm supposed to say yes to this :P 
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: Low risk
[Why is the change risky/not risky?]: The old padding values still exist and haven't changed, we're simply adding extra padding information in the way required by android for RTL.
[String changes made/needed]: None
Attachment #8835260 - Flags: approval-mozilla-aurora?
Comment on attachment 8835260 [details]
Bug 1338027 - Fix RTL padding in the linear tabs layout.

Fix an RTL padding issue in the linear tabs. This polish the UI. Aurora53+.
Attachment #8835260 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.