Match updated spec for `/\b/iu` and `/\B/iu`

RESOLVED FIXED in Firefox 54

Status

()

RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: arai, Assigned: arai)

Tracking

Trunk
mozilla54
Points:
---

Firefox Tracking Flags

(firefox54 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
related to bug 1281739.
\b and \B should also be updated to follow the change in https://github.com/tc39/ecma262/pull/525
(Assignee)

Comment 1

2 years ago
Created attachment 8835803 [details] [diff] [review]
Update word boundary in RegExp with unicode and ignoreCase flags to include U+017F and U+212A.

  * Changed BoyerMoorePositionInfo to use kIgnoreCaseWordRanges for iu flags
  * Changed EmitWordCheck to avoid using optimized path for iu flags
    (maybe we could add optimized path tho...)
  * Changed EmitWordCheck to check 0x017F and 0x212A for iu flags
Assignee: nobody → arai.unmht
Status: NEW → ASSIGNED
Attachment #8835803 - Flags: review?(till)
Comment on attachment 8835803 [details] [diff] [review]
Update word boundary in RegExp with unicode and ignoreCase flags to include U+017F and U+212A.

Review of attachment 8835803 [details] [diff] [review]:
-----------------------------------------------------------------

Looks great, thanks!
Attachment #8835803 - Flags: review?(till) → review+
(Assignee)

Comment 3

2 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/c043f1737e222180549cb754ddd2e83f0d2223bd
Bug 1338373 - Update word boundary in RegExp with unicode and ignoreCase flags to include U+017F and U+212A. r=till

Updated

2 years ago
Duplicate of this bug: 1321664

Comment 5

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/c043f1737e22
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox54: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla54
You need to log in before you can comment on or make changes to this bug.