Status

()

Firefox
Sync
RESOLVED DUPLICATE of bug 1295122
a year ago
a year ago

People

(Reporter: g.balachandu, Unassigned)

Tracking

52 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20170206101855

Steps to reproduce:

Signed in into firefox using my existing account.


Actual results:

Bookmarks are synced but, saved logins is empty. Even firefox is not prompting to remember password when I try to login into a site.


Expected results:

It should sync saved logins as well along with bookmarks, addons.
It should prompt to remember password.

Comment 1

a year ago
> Signed in into firefox using my existing account.

How exactly do you "sign into Firefox"? Do you refer to several user profiles on the same computer?
Flags: needinfo?(g.balachandu)

Updated

a year ago
Component: Untriaged → Sync
Summary: saved logins → saved logins not synced
(In reply to Andre Klapper from comment #1)
> > Signed in into firefox using my existing account.
> 
> How exactly do you "sign into Firefox"? Do you refer to several user
> profiles on the same computer?

The reporter is talking about signing in to their Firefox Account, used by Sync.

Could you please follow the instructions at https://wiki.mozilla.org/CloudServices/Sync/File_a_desktop_bug and look for any sync logs available on your machine and upload them here. If you can't find any error logs, please follow the instructions to get "success" logs instead - I suspect they will give us the clues we need here.
(Reporter)

Comment 3

a year ago
I sign using the following steps.
1) Opening the menu (3 bars on top right of browser)
2) Then click on sync button (bottom of the menu).
3) It opens a new window asking for credentials.
4) Then I entered the credentials and signed-in.
(Reporter)

Comment 4

a year ago
any update on this?
(In reply to g.balachandu from comment #4)
> any update on this?

Please see comment 2 - we need to see some logs to try and determine what is going wrong.
(Reporter)

Comment 6

a year ago
Created attachment 8841426 [details]
error-sync-1487308196720.txt

Please check the logs in the attached file.
Thanks! The key part of the logs here is:

> Failed to save data to the login manager: TypeError: Services.logins is undefined (resource://gre/modules/FxAccountsStorage.jsm:531:7) JS Stack trace: LoginManagerStorage.prototype.set<@FxAccountsStorage.jsm:531:7

So this is bug 1295122. Unfortunately we don't really have a good fix for this yet. I suspect the profile you are using has no saved passwords, so a possible workaround for you would be to exit the browser, delete logins.json and key3.db from your profile (after taking a copy of them), and restarting. Saved passwords, including the sync credentials, should then start working (ie, you should then be prompted once more to connect to Sync, after which things should work normally.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(g.balachandu)
Resolution: --- → DUPLICATE
Duplicate of bug: 1295122
(Reporter)

Comment 8

a year ago
This workaround did not work for me.
Can you try again, and after restarting, open the "Browser Console" (https://developer.mozilla.org/en/docs/Tools/Browser_Console) and paste the message from there into an attachment here? Deleting those 2 files solves all occurrences of "Services.logins is not defined" that I've seen, but yours might be different. Also, if you are familiar with IRC, you could join the #sync channel (https://wiki.mozilla.org/IRC) and we might be able to help further.
You need to log in before you can comment on or make changes to this bug.