Closed Bug 1338523 Opened 3 years ago Closed 3 years ago

Crash in mozilla::ipc::PrincipalInfo::AssertSanity

Categories

(Core :: Storage: IndexedDB, defect, critical)

Unspecified
Windows 7
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1337522
Tracking Status
firefox54 + fixed

People

(Reporter: marcia, Assigned: bkelly)

References

Details

(Keywords: crash, regression)

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-89982a69-2602-4508-96e9-db3812170209.
=============================================================

Seen while looking at nightly crash stats - crashes started with 20170208030203 build: http://bit.ly/2lyaGps

Possible regression range: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=af8a2573d0f1e9cc6f2ba0ab67d7a702a197f177&tochange=3a95aa4246653a7863914ffec032897d13359fb0
This is most likely due to bug 1333573.  I'd like to fix bug 1337522 first and see if it helps here.
Assignee: nobody → bkelly
Blocks: 1333573
Status: NEW → ASSIGNED
Adding a similar signature since it shows up with the same regression range.
Crash Signature: [@ mozilla::ipc::PrincipalInfo::AssertSanity] → [@ mozilla::ipc::PrincipalInfo::AssertSanity] [@ mozilla::ipc::PrincipalInfo::PrincipalInfo]
[Tracking Requested - why for this release]:

Let's make sure we don't release this crash regression.
Keywords: regression
Tracking 54+ for this crash regression.
This could be because we assume the PrincipalToPrincipalInfo() always succeeds.  This may not be the case under OOM conditions, etc.  Lets try making it fallible and see if the crashes go away.
My best guess is that the PrincipalToPrincipalInfo() call is failing, but we just ignore it in non-DEBUG builds.  There are a lot of error returns in that method, so its probably not reasonable to assume success in all cases.

https://dxr.mozilla.org/mozilla-central/source/ipc/glue/BackgroundUtils.cpp#132

Lets make SetPrincipalOnMainThread() fallible so we can properly handle any errors.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=162bb60cb7c1275cf441bcdb75e5ba60287b0df9
Attachment #8836094 - Flags: review?(amarchesini)
Attachment #8836094 - Flags: review?(amarchesini) → review+
Pushed by bkelly@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/21e33ec545a1
Make worker SetPrincipalOnMainThread fallible. r=baku
Let's leave this open until we see if the crashes are helped by comment 7 commit.
Keywords: leave-open
See Also: → 1338299
Backout by bkelly@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/88674db2fe97
Backout 959dce51f8cb for incorrect bug number in commit message. r=me
Note comment 9 backout was prior to comment 7.  I accidentally landed this with the wrong bug number and had to fix it.
Depends on: 1337522
Iteration: --- → 54.2 - Feb 20
This was last seen in build id 20170214030231.  So it appears bug 1337522 fixed it.
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
No longer depends on: 1337522
Resolution: --- → DUPLICATE
Duplicate of bug: 1337522
Iteration: 54.2 - Feb 20 → ---
Removing leave-open keyword from resolved bugs, per :sylvestre.
Keywords: leave-open
You need to log in before you can comment on or make changes to this bug.